[OJS 3.3.0.8] Port 8080 added when trying to load current issue via Chrome on Android smartphone

Hello anyone,

Description of issue or problem I’m having:
Accessing the current issue link is throwing a page not found error, because the link
v. 50 n. 1 (2021) | Ciência da Informação is changing to HTTPS and adding port 8080 after the domain.

The URL becomes: https://revista.ibict.br:8080/ciinf/issue/current which doesn’t exist.
All other links in the main menu work.

Steps I took leading up to the issue:
This happened in the following conditions:

  1. Clicking the URL received via e-mail notification of new issue published, on a notebook connected to a wi-fi network we provide at work;
  2. Clicking the same link copied and pasted through Whatsapp on 2 Android phones connected to the same network. Strangely, I tested on 4G at work and the link opened fine.;
  3. Tonight I tested at home, through ethernet cable and wifi on notebook and all links work;
  4. Same test on my phone at home on Wi-Fi generates the error.

Seems like Chrome can’t work out the link.

We have mod_rewrite enabled and this has worked so far. This is the first time we encounter this error.

What I tried to resolve the issue:
Resetting wi-fi connections, using 4G, but no solution.
We have reported this also to our IT network, is it may be caused by a reverse proxy setting somewhere.

Application Version - e.g., OJS 3.1.2:
OJS 3.3.0.8

Additional information, such as screenshots and error log messages if applicable:
problema-https-via-wifi

Hi Ramon,

What’s the value of the base_url key in your config.inc.php? Does it happen to have a port explicitly described in there?

Janio

Hello @janiosarmento ,

No, we have base_url and all other urls in the journal array with no port defined.
Just that link generates an error and only on WiFi connections, which is really odd.

I also checked sites-enabled files to see if any port or HTTPS had been added, but they’re all the same configurations for the past couple of years or more.