[OJS 3.3.0.8] CrossRef Reference Linking plugin not working on all reference lists

Description of issue or problem I’m having:
In one of my journals, the Crossref Reference Linking plugin does not appear to parse the references entered for some submissions.

Normally, reference lists appear on published metadata page with line spacing added between references immediately upon publication (example 1) and then the DOIs for the references are extracted and linked when determined by the chron job.

In the problem cases (example 2), the published reference lists retain single line-spacing and DOIs are not extracted.

Steps I took leading up to the issue:
Admin: install, update, and activate CrossRef Reference Linking plugin
Authors: create submission.
Editors: editorial workflow then publish the submission.

I do not know whether it was the author or editor who entered the reference metadata in either case; in both cases, the reference lists were added prior to initial publication.

What I tried to resolve the issue:
I tried unpublishing and republishing the submission but the reference list did not reformat (ie, the line spacing between references did not appear) and the DOIs were not extracted. I refreshed the browser cache when looking at the published reference list to ensure that this isn’t a cache issue.

To get a problem submission like example 2 to reformat and extract DOIs successfully, I have to

  1. unpublish the submission,
  2. cut the reference list out of the metadata
  3. paste it back in (no changes required)
  4. click Save
  5. Schedule for publication

This process does not work if I skip steps 2 and 3. I’m totally confused why these are necessary.

I would like for the reference lists to be parsed properly without having to unpublish and tweak the reference metadata in the back end.

Application Version - e.g., OJS 3.1.2:

OJS 3.3.0.8

Additional information, such as screenshots and error log messages if applicable:

Hi @tmrozewski,

Could you please let us know which version of the plugin you are using? There was an update released with some bug fixes in March of this year. Is this the version you are currently using?

Thank you,

Kate

v1.0.2.1 I believe this has been in place since shortly after the bug fix came out.