OJS 3.3.0-7 CrossRef Export Plugin XML v.4.4.2?

Hello, we are trying to export some XML with the CrossRef plugin. We manually send the XMLs to a printing press, but the issue is that they are on XML v4.4.2, while the plugin is on the v4.3.6 XML format.

Is there an update to the plugin that can help me solve this issue? My plugin gallery is not working right now, so I cannot see the plugins and their updates.

Thank you in advance!

Application Version - OJS 3.3.0.7

May I please bump this question? It is really important. Thank you!

Hi @Andrei-Cristian_Negu,

Can you take a look at the PHP log for associated errors, e.g., reproduce the error and check the log?

Hello!

Thank you for your reply. I cannot access the error logs. I’ve enabled error logging, but not error logs appear to generate. The plugin marketplace list simply does not update. How can I reproduce this?

Thank you!

It’s impossible to say what the problem is without the error message. There definitely should be one.
To see the relevant message, check the log just after reproducing the error - trying to visit plugin gallery page in your case.

The person, who administrates the server, should have access to PHP log.

Also, I don’t completely understand what the problem is with exported XML. Can you explain it in more detail? This XML is aimed to be uploaded to the CrossRef content registration system but not to the other press.

Hello!

Here is the mail we’ve received from CrossRef:

Many thanks for your email.

It’s a good start, there were quite a few errors in the file but the main format looks good. It would need to follow the schema here: Schema documentation for namespace http://www.crossref.org/schema/4.4.2

You can also check the file using our parser here: crossref.org : metadata quality check

Then rectify any errors and send it over to us.

I hope this helps and if you have any further question or queries on this then please do not hesitate to contact us again.

Many thanks,

They are telling us that the schema used by OJS3 (v4.3.6) is no longer compatible with the schema used by Crossref (v4.4.2). I hope I managed to better convey the issue.

I can also assure you that no logs are generated within the logs folder on my installation of OJS3. However, the plugin gallery has stopped working without any particular reason some time ago.

Thank you in advance for your patience and continuous support! I love this platform.

1 Like

Hello,

Any news related to this issue? Thank you!

Hi @Andrei-Cristian_Negu,

Hmm, I performed a test and successfully registered metadata using http://www.crossref.org/schema/4.3.6 in imported XML. I have generated it with the plugin shipped twith OJS 3.2.1. So, it shouldn’t be an issue. Anyway, I let my team members know about it, as I’m not an expert in this field.
edit Also found on the Crossref site that 4.3.6 is supported: Schema versions - Crossref

Unfortunately, without an error message from the log, I can’t help to solve the issue with the plugin gallery page. Ask you hosting provider / a person who is responsible for hosting your OJS instance to provide PHP log. If page doesn’t load, there should be a fatal error indicating the reason.

1 Like

Dear @Vitaliy , dear @Andrei-Cristian_Negu
do you know if there are any enhancements to the Crossref Plugin in wild out there? The plugin indeed uses one of the oldest and most simple schema. Younger schemas would allow for richer data like affiliations or maybe even additional locales than the main one. See this one too: Does the Crossref Export Plugin include affiliation? - #2 by shaun
In other words: Are there any plans to adopt the plugin to the latest Crossref schema?
Thanks and all the best
Klaus