OJS Slim Application Error and PDO Exception

I am not able to edit submissions in the workflow before publishing. For example, I would like to make a few edits to the Abstract and references based on the reviewed copy. I also discovered that I could not upload new submissions.

Here is the error log for it

[26-Jan-2022 13:45:13 UTC] Slim Application Error:
Type: Illuminate\Database\QueryException
Code: 22007
Message: SQLSTATE[22007]: Invalid datetime format: 1366 Incorrect string value: ‘\xEF\xAC\x81ltr…’ for column ‘setting_value’ at row 1 (SQL: insert into publication_settings (publication_id, locale, setting_name, setting_value) values (247, en_US, abstract, <p><em>MESSAGE I WAS TRYING TO EDIT publication_id = values(publication_id), locale = values(locale), setting_name = values(setting_name), setting_value = values(setting_value))
File: /home/futajeet/public_html/lib/pkp/lib/vendor/laravel/framework/src/Illuminate/Database/Connection.php
Line: 671
Trace: #0 /home/futajeet/public_html/lib/pkp/lib/vendor/laravel/framework/src/Illuminate/Database/Connection.php(631): Illuminate\Database\Connection->runQueryCallback(‘insert into pu...', Array, Object(Closure)) #1 /home/futajeet/public_html/lib/pkp/lib/vendor/laravel/framework/src/Illuminate/Database/Connection.php(496): Illuminate\Database\Connection->run('insert into pu…’, Array, Object(Closure))
#2 /home/futajeet/public_html/lib/pkp/lib/vendor/staudenmeir/laravel-upsert/src/Query/Builder.php(92): Illuminate\Database\Connection->affectingStatement(‘insert into `pu…’, Array)

Here is another one

Previous error:
Type: PDOException
Code: 22007
Message: SQLSTATE[22007]: Invalid datetime format: 1366 Incorrect string value: ‘\xEF\xAC\x81ltr…’ for column ‘setting_value’ at row 1
File: /home/futajeet/public_html/lib/pkp/lib/vendor/doctrine/dbal/lib/Doctrine/DBAL/Driver/PDOStatement.php
Line: 115
Trace: #0 /home/futajeet/public_html/lib/pkp/lib/vendor/doctrine/dbal/lib/Doctrine/DBAL/Driver/PDOStatement.php(115): PDOStatement->execute(NULL)
#1 /home/futajeet/public_html/lib/pkp/lib/vendor/laravel/framework/src/Illuminate/Database/Connection.php(489): Doctrine\DBAL\Driver\PDOStatement->execute()
#2 /home/futajeet/public_html/lib/pkp/lib/vendor/laravel/framework/src/Illuminate/Database/Connection.php(664): Illuminate\Database\Connection->Illuminate\Database{closure}(‘insert into pu...', Array) #3 /home/futajeet/public_html/lib/pkp/lib/vendor/laravel/framework/src/Illuminate/Database/Connection.php(631): Illuminate\Database\Connection->runQueryCallback('insert into pu…’, Array, Object(Closure))

I look forward to your urgent response.

I’m still waiting for your response…

Apologies for tagging… I need to get the issue resolved quickly as it’s affecting the reputation of our journal.


I am still awaiting a response to this issue. It’s beyond a week now. I understand there are a lot of issues to handle but I do need your urgent response.

This has been affecting the integrity of persons managing the journal system since this is the first of its kind thing in my university.

Thanks and regards to all admins

Hi @oyedeyeye,

What Database do you use and what is the encoding of your DB, DB tables and maybe also specifically of that ‘publication_settings’ table?
Also what do you have in your file config.inc.php under Localization Settings?
Did all this work earlier? – it sounds like it worked (since you were able to submit articles) and now in does not work (suddenly you cannot submit an article?). Have something changed (server, DB, OJS upgrade,…) in the meantime?


Thank you for your response.

Here is brief information from my config.inc.php

driver = mysqli

Under Localization Setting, Here is what is there:

; Localization Settings ;


; Default locale
locale = en_US

; Client output/input character set
client_charset = utf-8

; Database connection character set
connection_charset = utf8

It all worked earlier until I needed to update the abstract of some published articles and also change the uploaded galley.

That was where the problem started. I later could not make a new submission.

Nothing changed, In the meantime, I have had to replace all the OJS files with a fresh file.

I mean performing upgrade with the same version files… It seem to solve the problem by 90%

Hi @oyedeyeye,

And what is the encoding of your DB tables? – it seems like trying to save the characters composed with 4 bytes and MySQL encoding supports at maximum characters composed by 3 bytes…
See also this issue: Unicode math italics/bold truncates text notes · Issue #7663 · pkp/pkp-lib · GitHub