Ojs Failed Ajax request or invalid JSON returned when trying to add reviewer

Description of issue or problem I’m having:
Whenever an article gets to the review stage the folowing message appears:
“Failed Ajax request or invalid JSON returned when trying to add reviewer”

Steps I took leading up to the issue:

  • Article gets submitted
  • An editor is assigned and the article is moved to the review stage
  • When we try to add a reviewer the error occurs

What I tried to resolve the issue:

  • I tried manually resubmitting the article from a different user
  • I reinstalled ojs and imported the database
  • The error log on my server states:

AH01071: Got error ‘PHP message: Malformed UTF-8 characters, possibly incorrectly encoded’, referer: Login | Obstetric and Gynecological Imaging

  • So i tried to delete all the files submitted and check the author names but i could not find the cause.
    Thanks in advance for your help!

Application Version - e.g., OJS

We are also encountering an issue similar to the one reported.
I tested versions 3.3.0-6 and 3.3.0-7
Submissiions => assign the edit (previously created)

Any tips on how to solve?

Augusto Torres
Server information: PHP-7.3, Apache2.4, MySQL 5.4

Hello there! After creating a second test article i found out that the problem was not there!
After comparing the 2 articles i found out that some special characters in the submission of the metadata of the article (Abstract, Title or Subtitle) caused the issue.

I copy pasted the title and abstract line by line after that only to find out that a “;” (greek questionmark) & and apostrophe " ’ " in the text caused the crash in the specific article.

I also found another article with the same problem but this time it had other characters (attaching screenshot).

What led me to this was the php-log on my server so i don’t know if that’s the case for you. But it’s worth a shot.!

I finally managed to solve this problem…
As we are using this system in a “well crap by the way” hosts provider, we don’t have access to the files via shell, also the files need to be sent using FileZilla to the host folder.
During these file transfers, the file “assignToIssue.tpl” was missing
which is inside the folder “templates/controllers/modals/publish/”
Augusto Torres

This topic was automatically closed after 4 days. New replies are no longer allowed.