[OJS] Author Role for New Users

  • Application Version - OJS
  • Description of issue
    I know this has come up several times before in previous versions, but new users are not assigned the author role by default and get an error when they try to make a submission - “The current role does not have access to this operation”.
  • Steps you took leading up to the issue
    Recent upgrade to OJS
  • What you tried to resolve the issue
    Checking administrator tabs and user roles. I can’t find any options to give users the author role by default.

I remember this used to be an issue mainly if someone indicated that they were willing to review when registering. This would give them the reviewer role but not allow them to make submissions. I recall a workaround being to show users a “Make submission” button, but when new users click on it they have get the error message. In a test account I made, it seemed to work the second time around, but telling people to try again until the error message goes away isn’t really a good solution.

Is there a way to give new users the author role by default?

Hi @shaun,

I think that this is by design, and that users have to opt-in to being assigned particular roles. There appears to be some extensive discussion and related work on this topic here: Make reader and author registration optional / opt-in · Issue #3600 · pkp/pkp-lib · GitHub. - I believe that a number of these changes would’ve been in place from 3.2 moving forward. @NateWr might be able to elaborate on some of this and confirm that it is the case, or if anything has changed.

PKP Team

Thanks @rcgillis

But my journal is open access, so the main reason someone would register themselves is to submit papers. When they register, there is no option saying “I want to submit papers”. We would have to instruct them to dig through the profile options to give themselves an ‘author role’ after registering. This is out of step with what they expect to be able to do. Every other system allows people to register as an author and get started submitting papers without needing to locate specific settings or ask the journal for support.

@shaun I was not able to reproduce the issue you describe in 3.3.0-6. Can you describe in more detail the steps you take when having this problem? Here are the steps that I took:

  1. Access journal as logged out user.
  2. Go to login page, click on register, and enter details.
  3. Click the register button.
  4. See a link to make submissions.


Is it possible that you have disabled self-registration for all author roles in your journal? You can check this by going to Settings > Users & Roles > Roles. Edit any author roles and see if at least one has the checkbox checked that allows self-registration.

Thanks @NateWr. When my user first told me about it, I logged into their account from my journal manager/administrator account and was able to replicate it via the new submission button. I have email authentication switched on, so my new users don’t see the screen you showed - but they do get the option to make a new submission when they log in.

I also tried replicating by creating a new user and logging in from my administrator account - which replicated the error once, but not a second time.

Today, I tried creating a couple of new accounts (not logged in) and seeing what happens. It strangely seems to work sometimes but not others. So as a new user, I will sometimes be able to access the submission role, with or without the author role. It seems as though if a new user checks the “Yes, I would like to be notified of new publications and announcements” box, then they get the reader but not the author role, but if they leave it unchecked, they get both.


As a new user, I can self-assign the author role, click on “Back to New Submissions” and it lets me into the submission wizard. Then, if I un-assign the author role, I can go do the same thing and sometimes I will get the following error message and other times it shows the submission wizard.


However once I get this error, without changing any settings, I can then click on “Submit manuscript”, follow the link to “Make a new submission” and I’ll get back into the submission wizard.

I can also get this error consistently if a user without the author role clicks “Cancel” in the submission wizard. Users with the author role can go to their submission dashboard.

It’s pretty strange behaviour and doesn’t seem to happen consistently.

1 Like

Thanks for investigating further, @shaun. Can you try switching to the default theme and deactivating the orcid profile plugin, then see if you can reproduce the problem? That will help us narrow down the source of it and hopefully we can reproduce it on our end.

Hi @NateWr

To avoid interfering with my production instance, I made a fresh OJS installation and tried again. I can reproduce the problem with the following steps.

  1. Register a new user

  2. Go to make new submission [Works]

  3. Cancel the new submission

  4. Register a new user

  5. Start a new submission

  6. Go to user profile

  7. Unassign the author role (even though doing this doesn’t make sense)

  8. Attempt to go “Back to new submission” [“The current role does not have access to this operation.”]

One thing I noticed is that sometimes, depending on the user’s roles, they will see a link to “Back to new submission” or “Back to submissions”.


If they have the author role they can see a “Back to submissions” link.

If you unassign the author role (even though that’s a weird thing to do), you can reliably replicate the “The current role does not have access to this operation.”

So I think I’ve figured out what might be happening here:
Links that go to [journalpath]/submission/wizard tend to work
Links that go to [journalpath]/submissions produce the “current role” error.

To test this, I registered another new user, but instead of clicking on the “Make new submission link”, I went to the ‘About - Submissions’ page.

From there I am offered both “Make a new submission” and “view your pending submissions” links:

If I click on the former, I get to the submission wizard OK. If I click on the latter, I get the “current role” error.

This makes more sense. If a user wants to check the guidelines before making a submission, they might register and not go straight to the submission wizard. Instead, they might take a look at the submission guidelines before going to upload their files. If they click on the “view your pending submissions” link instead of the “Make a new submission” link, then they’ll get the error and think they’re unable to make submissions.

Thanks for this careful investigation, @shaun. I’ve filed this a a bug and you can follow progress here:

1 Like

This topic was automatically closed after 13 days. New replies are no longer allowed.