OJS and disappearing submission_file_settings table

Not sure if you’ve run into this problem before, but any help would be greatly appreciated. We’ve upgraded two instances from 3.1.2 and despite both upgrades being successful and working, the next day every journal is a blank page and the whole database is corrupt. In both cases ‘submission_file_settings’ is the problematic table:

MySQL said: Table ‘ojs.submission_file_settings’ doesn’t exist in engine

Here’s what the output in the PHP error logs looks like:

[Tue Jun 01 10:01:00.009351 2021] [php7:error] [pid 3656] [client] PHP Fatal error: Uncaught PDOException: SQLSTATE[42S02]: Base table or view not found: 1932 Table ‘ojs_guelph.submission_file_settings’ doesn’t exist in engine in /data/apache-html/2_stable-3_3_0-guelph/lib/pkp/lib/vendor/doctrine/dbal/lib/Doctrine/DBAL/Driver/PDOConnection.php:79\nStack trace:\n#0 /data/apache-html/2_stable-3_3_0-guelph/lib/pkp/lib/vendor/doctrine/dbal/lib/Doctrine/DBAL/Driver/PDOConnection.php(79): PDO->prepare(‘SELECT * FROM s…’, Array)\n#1 /data/apache-html/2_stable-3_3_0-guelph/lib/pkp/lib/vendor/laravel/framework/src/Illuminate/Database/Connection.php(361): Doctrine\DBAL\Driver\PDOConnection->prepare(Object(Illuminate\Database\Query\Expression))\n#2 /data/apache-html/2_stable-3_3_0-guelph/lib/pkp/lib/vendor/laravel/framework/src/Illuminate/Database/Connection.php(664): Illuminate\Database\Connection->Illuminate\Database\{closure}(Object(Illuminate\Database\Query\Expression), Array)\n#3 /data/apache-html/2_stable-3_3_0-guelph/lib/pkp/lib/vendor/laravel/framework/src/Illuminate/Database/Connection.php(631): in /data/apache-html/2_stable-3_3_0-guelph/lib/pkp/lib/vendor/laravel/framework/src/Illuminate/Database/Connection.php on line 671, referer: https://www.criticalimprov.com/index.php/csieci/management/settings/website?r=60b63d8217c60

Any ideas as to why this is happening? It’s really frustrating because it’s causing a lot of lost work.

1 Like

We have never experienced something like that … but a shoot in the dark … could there be a cronjob configured that could be messing with the database overnight?

the submission_file_settings is the only table that doesn’t exist anmore?

Yes seems to be just submission_file_settings.

These are the cron jobs we have set for each OJS:

0 5 * * * php /var/www/html/guelph/tools/runScheduledTasks.php /var/www/html/guelph/registry/scheduledTasks.xml > /dev/null 2>&1 0 5 * * * php /var/www/html/guelph/tools/runScheduledTasks.php /var/www/html/guelph/plugins/generic/usageStats/scheduledTasksAutoStage.xml > /dev/null 2>&1 0 5 * * * php /var/www/html/guelph/tools/runScheduledTasks.php /var/www/html/guelph/plugins/importexport/crossref/scheduledTasks.xml > /dev/null 2>&1 0 5 * * * php /var/www/html/guelph/tools/runScheduledTasks.php /var/www/html/guelph/plugins/importexport/datacite/scheduledTasks.xml > /dev/null 2>&1 0 5 * * * php /var/www/html/guelph/tools/runScheduledTasks.php /var/www/html/guelph/plugins/importexport/doaj/scheduledTasks.xml > /dev/null 2>&1 0 5 * * * php /var/www/html/guelph/tools/runScheduledTasks.php /var/www/html/guelph/plugins/importexport/medra/scheduledTasks.xml > /dev/null 2>&1 0 5 * * * php /var/www/html/guelph/tools/runScheduledTasks.php /var/www/html/guelph/plugins/generic/pln/xml/scheduledTasks.xml > /dev/null 2>&1

With the first database that we did this with we restored all of the tables from a backup where ‘submission_file_settings’ still worked to a new database and it’s been working fine since.

Hi @bart,

Does the table submission_file_settings actually exist? I would say that according to the error message something is wrong with MySQL environment rather than the table.

Thanks @Vitaliy and @hilongo. We just restored into a new db, which worked last time. We still can’t figure out what caused the table to disappear, but will post back when we figure it out.

1 Like

This topic was automatically closed after 6 days. New replies are no longer allowed.