(OJS 3.3.0-13) Clicking on PDF redirects to search page

Describe the issue or problem
In one issue recently published by one of our journals, if you click on the PDF button for any of the articles, you are redirected to a search page instead of being shown the PDF. This seems to be the same problem or similar to the one described in https://forum.pkp.sfu.ca/t/ojs-3-0-2-solved-readers-get-redirected-to-the-advanced-search/28775/28.

If you are logged in as an admin or as the journal manager, the PDF buttons do work as expected, but if you are not logged in or if you’re logged in as an author, you get redirected to the search page.

The PDF button for the whole issue is functioning, and the PDF buttons on each article landing page appear as expected.

The PDF also opens successfully from the galleys page of the publication tab for each submission.

I tried unpublishing and republishing the issue, but it didn’t help. I also tried removing each PDF and then re-adding them, but that also didn’t work.

A couple of things I can think of that may be related to the problem:

  1. The editor accidentally published the issue without any PDFs for the articles. I later unpublished the issue and added in the PDFs.

  2. When I checked the access settings under Distribution > Access (after the issue had been published), it was not set to “The journal will provide open access to its contents.” When I noticed this, I selected this option and then unpublished and republished the issue.

What can I do to fix this? I wasn’t able to get a clear answer from the other posts about the same/similar issues that I found in the Forum.

What application are you using?
OJS 3.3.0-13

Additional information
Please add any screenshots, logs or other information we can use to investigate this problem.