OJS Can't download files

Describe the issue or problem
Hi guys!

I’m having some trouble when downloading files from my journal.
We have some templates and guidelines for authors to download, but after upgrading to it isn’t working as it should.

Steps I took leading up to the issue
When you click on the download link it shows the error 404 Not Found, The requested URL /ojs/document.docx was not found on this server.
At first it didn’t work with .pdf files, but .docx downloaded just fine. Now nothing is working.

What application are you using?
We were working with, but last saturday we upgraded to and then finally to

Additional information
So far I checked and tried this things:
*Files are in fact where they are supposed to.
*File names, extensions, permissions and owner are the same as they were on
*Download link is pointing to the right path (same as
*I have tried giving the files 775 permissions.
*I changed directories and download path.
*Tried uploading new files.
*Tried changing file names.

But so far nothing helped. I still get the 404.

Thank you so much for your help! and if you need any specific information just let me know.