[OJS 3.1.2] Links not working on Home page

I have OJS 3.1.2 (upgraded from 2.38 → 2.4.6)

Links on index page are not working, when I click any of them, login form is opened. I need to fix this, can’t even open registration form.
There are no errors in php error.log, just once I saw this error:
[31-May-2019 09:55:47 Europe/Belgrade] PHP Warning: Declaration of RegistrationHandler::validate($request) should be compatible with PKPHandler::validate($requiredContexts = NULL, $request = NULL) in C:\inetpub\wwwroot\siteurl\lib\pkp\pages\user\RegistrationHandler.inc.php on line 19

I am using default theme

Hi @Dragoljub_Djordjevic

That warning is cosmetic. Can you post an example of a link that isn’t working?


Any link on the index/login page opens login form. Even when I click on register (registrations are allowed in journal settings). This is updated version from ojs 2.3.6

I have (new, with test journal) local installation of ojs and everything works fine.

After the upgrade, did you “re-save” the forms which determine journal access? I’m wondering if there may be some fields in the database with no/old values.


Please explain this a bit more.

There’s quite a difference between 2.3.6 and 3.1.1-4. There may be journal settings that are new to 3.1.1-4 that may behaving incorrectly because there are no preset defaults, or the old values in them do not apply. You should go through all of your journal settings forms and make sure they correct and click save on each one.

I have 3.1.2 not (I installed older version just for test).
I went trough all journal settings, but it didn’t help. Everything works fine when user is logged in, but on index page, where users should register, only login form works. If I click on register or any other link (language, about, etc…) login form is opened. We have more than 80 journals, I need to find solution before we move to production server

Is your upgrade/test server publicly available? Feel free to DM me a link.

No, it isn’t. . I don’t even see any errors in console or php error log, so I don’t have idea where to start looking. Could it be some db setting?

I have just created a new test journal and everything works fine (for new journal only). I can send you db entries from journal_setting for two test journals if you are willing to take a look. Or maybe you need entries from some other table?

Found the solution…
In table ‘journals’, all journals were disabled, except new one that I created . (Column ‘enabled’ = 0).

1 Like

Glad that you found the fix, but that’s a weird one. I’ve done a few upgrades from 2.4 to 3.1 that haven’t had that issue, but I don’t think I’ve gone that far back, recently. I have one of those on my plate soon and I’ll keep this thread in mind.

Thank you for your help.

I just checked db on production server, which is still on version 2.3.6, and all journals are also disabled. So it is not upgrade problem, maybe someone changed that setting intentionally couple of years ago.

where to find journal tables

Where to find table called journals
Can you mention the path

There is a table called ‘journals’ in your database. Do you have access to your database?

here it is where to find it?


This doesn’t look like OJS database, more like Wordpress or something similar. What are you trying to do?