OJS 3.1.2 ##common.file.namingPattern##


Context: New to OJS; after a successful upgrade from 3.1.1 to 3.1.2 from main git repo (i.e. as updated as can possibly be). EN has only locale.

All working well, but making a new submission yields ##common.file.namingPattern## to be shown on the form, visibly stopping the upload process as users are not permitted to click “Continue” to go to the third “Confirm” tab. Upon closing the pop-up and refreshing the page, however, it appears the file is uploaded with ##common.file.namingPattern## as name.

Any thought on what might be going on?



44 52

That’s probably related; it seems that the form doesn’t access/store information more widely, not just on filenames. When filling in metadata, and pressing save, OJS complains of missing fields that are in fact fileld up.


I am still having issues with this one; I have reinstalled a number of times, and pulled in the latest commits from git stable-3_1_2, but that hasn’t fixed it. @asmecher

I currently have only one primary locale (English). If I don’t tick “Forms” and “Submissions” in Settings > Website > Languages, then I get ##common.file.namingPattern## upon uploading of files, and the button Continue is greyed out. If I do tick “Forms” and “Submissions”, then upload works, but subsequent fields of metadata have that little red earth icon, opening two empty fields for localization. Unlike in my original post, in March, users don’t seem to be expected to fill in the added localization, and can complete submission filling in just the first boxes.



I am now starting to believe that this might be a database issue. Is that possible? My current 3.1.2 installation is an upgrade from 3.1.1, and in my various attempts to reinstall 3.1.2, I would not erase the database and start from scratch, and simply reuse my (empty) database. I am using Godaddy to host, and databases are a pain to manage with them…


Hi @eroesch,

It’s entirely possible that reusing an existing database would cause problems, especially if it was created with 3.1.1 and is now being used with 3.1.2. I’d suggest getting rid of your database, creating a fresh one, and starting the install process from scratch.

Alec Smecher
Public Knowledge Project Team

Great. Thanks @asmecher! I’ll try that in a few days. Hopefully it won’t be as much a pain as I anticipate it to be. I’ll report my findings here.

Okay: So. It was indeed a database issue. Scrapping and reinstalling the database solved the problem. I have noticed another issue, however, re user assignment to roles, which was already present before my latest reinstall. I will open a different Topic for that. Thanks again for your help, @asmecher!!

1 Like