[OJS 3.1.2.1] Pdfs problem

2019-08-14

help please

3.1.2.1

Hi @DGI_Investigacion,

Has anything changed in that installation recently, e.g. an upgrade to OJS?

Regards,
Alec Smecher
Public Knowledge Project Team

Thank you for your reply. I am working on this together with our tech specialist who posted this thread. We have installed a new 3.1.2 install on a new server and then we have manually uploaded back issues. So far, we have not gotten the HTML or PDF galleys to work, something seems to be blocking the frames from showing. The PDFs can be downloaded just fine, but they cannot be opened within the browser, since Chrome just shows the “(host address here) refused to connect” error.

Hi @Michael_White,

I’d suggest checking the browser’s debugging tools to see if you can identify what the server is giving the PDF.js client when it attempts to download the PDF.

Regards,
Alec Smecher
Public Knowledge Project Team

Thanks for the advice. I checked the Chrome debugger (Ctrl+Shift+J on Windows in Chrome) on the “refused to connect” page, and it showed this:

Refused to display ‘https://[journal URL]/plugins/generic/pdfJsViewer/pdf.js/web/viewer.html?file=https%3A%2F%2F[journal URL]%2Findex.php%2FRICTD%2Farticle%2Fdownload%2F514%2F508%2F’ in a frame because it set ‘X-Frame-Options’ to ‘deny’.

Right now we are trying the config options outlined here to change the X-Frame-Options header. I’ll edit this comment with an update once we give it a try.

EDIT: We tried adding the X-Frame-Options header to the Apache config, and we still are getting the same error. Any ideas on what else could be causing this ‘X-Frame-Options’ to ‘deny’ error?

Hi

I have a same problem, somebody found it the solution?

1 Like

I do not find the probelma friend