[OJS 3.1.2.0] Uploading a new plugin

Hi,
I am trying to upload a new plugin. It is for exporting metadata to ICI indexing. I keep getting this message whenever I try to save it:


I tried renaming the plugin file but it never worked out. I am working on OJS 3.1.2.0.
Looking forward to your response.
Regards,

Hi,
If your OJS version is 3.1.2, then;

  1. Please download the release corresponding to your OJS version, in this case copernicus-ojs3-0.0.4.tar.gz

https://github.com/a-vodka/ojs_copernicus_export_plugin/releases/download/0.0.4/copernicus-ojs3-0.0.4.tar.gz

  1. Extract the file on your computer because the version information in the version.xml file seems out of date and prevents install.

  2. Change the release date to 2019-05-23 and version to 0.0.4

  3. Make archive either as zip file, or tar.gz
    or download my file from cloud:
    Copernicus Plugin

Then you may install via upload plugin button, or via ftp etc.
5. Let’s not forget to thank @a-vodka

Regards,





1 Like

Dear @drugurkocak,
Thank you for your response and for the comprehensive explanation. However, I tried the solution you suggested but it did not work.
I still get the same message.
Regards,

Hi @Mouhammed_Jessam,

Can you check PHP logs for details?

Hi @Vitaliy,
How do I do that?

It depends. Are you using own server or shared hosting?

I am using shared hosting.

If you don’t have access to tar, gzip functions, than you may have similar errors. Do you have access to cpanel or another kind of web based file manager, so that you can upload plugin files to its directory. Is it a windows or linux server? So many possibilites.

Ask your hosting provider for php logs when error appears.