OJS 3.1.1 upgrade problem


#1

Hi, I did an upgrade from 3.0.1 to 3.1.1 through Softaculous, but there is some problem. I get different errors, from trying to log in to trying to access an article. I have no idea what to do. The error log says:
[Sun Apr 15 17:50:37 2018] [error] [client 109.242.94.199] PHP Notice: Undefined index: gossip in /home/zwfmqpxw/public_html/helenskestudije.me/ojs/lib/pkp/classes/user/PKPUserDAO.inc.php on line 316, referer: http://helenskestudije.me/ojs/index.php/jhs
[Sun Apr 15 17:50:37 2018] [error] [client 109.242.94.199] PHP Warning: mktime(): It is not safe to rely on the system’s timezone settings. You are required to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone ‘UTC’ for now, but please set date.timezone to select your timezone. in /home/zwfmqpxw/public_html/helenskestudije.me/ojs/lib/pkp/lib/adodb/adodb-time.inc.php on line 1073, referer: http://helenskestudije.me/ojs/index.php/jhs
[Sun Apr 15 17:46:53 2018] [error] [client 109.242.94.199] PHP Notice: Undefined index: gossip in /home/zwfmqpxw/public_html/helenskestudije.me/ojs/lib/pkp/classes/user/PKPUserDAO.inc.php on line 316, referer: http://helenskestudije.me/ojs/index.php/index/install/upgrade
[Sun Apr 15 17:46:53 2018] [error] [client 109.242.94.199] PHP Warning: mktime(): It is not safe to rely on the system’s timezone settings. You are required to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone ‘UTC’ for now, but please set date.timezone to select your timezone. in /home/zwfmqpxw/public_html/helenskestudije.me/ojs/lib/pkp/lib/adodb/adodb-time.inc.php on line 1073, referer: http://helenskestudije.me/ojs/index.php/index/install/upgrade
[Sun Apr 15 17:46:52 2018] [error] [client 109.242.94.199] PHP Notice: Undefined index: gossip in /home/zwfmqpxw/public_html/helenskestudije.me/ojs/lib/pkp/classes/user/PKPUserDAO.inc.php on line 316, referer: http://helenskestudije.me/ojs/index.php/jhs
[Sun Apr 15 17:46:52 2018] [error] [client 109.242.94.199] PHP Warning: mktime(): It is not safe to rely on the system’s timezone settings. You are required to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone ‘UTC’ for now, but please set date.timezone to select your timezone. in /home/zwfmqpxw/public_html/helenskestudije.me/ojs/lib/pkp/lib/adodb/adodb-time.inc.php on line 1073, referer: http://helenskestudije.me/ojs/index.php/jhs
[Sun Apr 15 17:46:44 2018] [error] [client 109.242.94.199] PHP Notice: Undefined index: gossip in /home/zwfmqpxw/public_html/helenskestudije.me/ojs/lib/pkp/classes/user/PKPUserDAO.inc.php on line 316, referer: http://helenskestudije.me/ojs/index.php/index/install/upgrade
[Sun Apr 15 17:46:44 2018] [error] [client 109.242.94.199] PHP Warning: mktime(): It is not safe to rely on the system’s timezone settings. You are required to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone ‘UTC’ for now, but please set date.timezone to select your timezone. in /home/zwfmqpxw/public_html/helenskestudije.me/ojs/lib/pkp/lib/adodb/adodb-time.inc.php on line 1073, referer: http://helenskestudije.me/ojs/index.php/index/install/upgrade
[Sun Apr 15 17:46:44 2018] [error] [client 109.242.94.199] PHP Notice: Undefined index: gossip in /home/zwfmqpxw/public_html/helenskestudije.me/ojs/lib/pkp/classes/user/PKPUserDAO.inc.php on line 316, referer: http://helenskestudije.me/ojs/index.php/index/install/upgrade
[Sun Apr 15 17:46:44 2018] [error] [client 109.242.94.199] PHP Warning: mktime(): It is not safe to rely on the system’s timezone settings. You are required to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone ‘UTC’ for now, but please set date.timezone to select your timezone. in /home/zwfmqpxw/public_html/helenskestudije.me/ojs/lib/pkp/lib/adodb/adodb-time.inc.php on line 1073, referer: http://helenskestudije.me/ojs/index.php/index/install/upgrade
[Sun Apr 15 17:46:44 2018] [error] [client 109.242.94.199] PHP Notice: Undefined index: gossip in /home/zwfmqpxw/public_html/helenskestudije.me/ojs/lib/pkp/classes/user/PKPUserDAO.inc.php on line 316, referer: http://helenskestudije.me/ojs/index.php/index/install/upgrade
[Sun Apr 15 17:46:44 2018] [error] [client 109.242.94.199] PHP Warning: mktime(): It is not safe to rely on the system’s timezone settings. You are required to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone ‘UTC’ for now, but please set date.timezone to select your timezone. in /home/zwfmqpxw/public_html/helenskestudije.me/ojs/lib/pkp/lib/adodb/adodb-time.inc.php on line 1073, referer: http://helenskestudije.me/ojs/index.php/index/install/upgrade

Please help!


#2

PS. I also tried upgrading DB using these instructions:
If you do not have the PHP CLI installed, you can also upgrade by running a
web-based script. To do so:

- Edit config.inc.php and change "installed = On" to "installed = Off"
- Open a web browser to your OJS site; you should be redirected to the
  installation and upgrade page
- Select the "Upgrade" link and follow the on-screen instructions
- Re-edit config.inc.php and change "installed = Off" back to
   "installed = On"

But when I click “Upgrade” link I get a blank page.


#3

When try to upgrade from 3.1.0.1 to 3.1.1 have this error
Duplicate entry ‘0-1’ for key ‘citations_submission_seq’
but I can not find the key in PhpMyAmin


#4

Hi @filipi,

But when I click “Upgrade” link I get a blank page.

This usually means a PHP error occurred. Check your PHP error log for details.

If the upgrade has already failed once (which is likely), note that you’ll have to restore it from backup before trying again.

@faud, your question isn’t the same as the original one; please post it as a new topic.

Regards,
Alec Smecher
Public Knowledge Project Team


#5

Thanks for your answer. Please see my first message where I copied the error log. Do you see there something that could help me?


#6

Hi @filipi,

The errors you quoted are warnings, and can be ignored, but I’m fairly sure you’ll find something with the word “error” in it if you look further back in the log.

Regards,
Alec Smecher
Public Knowledge Project Team


#7

Hi @asmecher, the errors I receive if I want to access an article from previous journal issue is DB Error: Unknown column ‘submission_id’ in ‘where clause’

When I try to login the error is DB Error: Unknown column ‘gossip’ in ‘field list’

There is obviously some problem with the DB update but I have no idea how to solve it. Most of the website is functional, except the key part - viewing articles.
Even when I get the login error I just refresh the browser and I’m in, so I have no clue about what is the problem.


#8

Does this mean something to you?

[Mon Apr 16 18:13:36 2018] [error] [client 109.242.94.199] PHP Fatal error: require_once(): Failed opening required ‘/home/zwfmqpxw/public_html/helenskestudije.me/ojs/lib/pkp/plugins/metadata/nlm30/PKPNlm30MetadataPlugin.inc.php’ (include_path=’.:/home/zwfmqpxw/public_html/helenskestudije.me/ojs/classes:/home/zwfmqpxw/public_html/helenskestudije.me/ojs/pages:/home/zwfmqpxw/public_html/helenskestudije.me/ojs/lib/pkp:/home/zwfmqpxw/public_html/helenskestudije.me/ojs/lib/pkp/classes:/home/zwfmqpxw/public_html/helenskestudije.me/ojs/lib/pkp/pages:/home/zwfmqpxw/public_html/helenskestudije.me/ojs/lib/pkp/lib/adodb:/home/zwfmqpxw/public_html/helenskestudije.me/ojs/lib/pkp/lib/phputf8:/home/zwfmqpxw/public_html/helenskestudije.me/ojs/lib/pkp/lib/pqp/classes:/home/zwfmqpxw/public_html/helenskestudije.me/ojs/lib/pkp/lib/smarty::/usr/local/php56/lib/php’) in /home/zwfmqpxw/public_html/helenskestudije.me/ojs/lib/pkp/includes/functions.inc.php on line 25, referer: http://helenskestudije.me/ojs/index.php/jhs/install/upgrade
[Mon Apr 16 18:13:36 2018] [error] [client 109.242.94.199] PHP Warning: require_once(/home/zwfmqpxw/public_html/helenskestudije.me/ojs/lib/pkp/plugins/metadata/nlm30/PKPNlm30MetadataPlugin.inc.php): failed to open stream: No such file or directory in /home/zwfmqpxw/public_html/helenskestudije.me/ojs/lib/pkp/includes/functions.inc.php on line 25, referer: http://helenskestudije.me/ojs/index.php/jhs/install/upgrade


#9

Hi @filipi,

That says that lib/pkp/plugins/metadata/nlm30/PKPNlm30MetadataPlugin.inc.php is missing from your installation.

Regards,
Alec Smecher
Public Knowledge Project Team


#10

Hi, again, after another update, I cannot complete the process. I receive error:

A database error has occurred: Duplicate entry '1-en_US-editorialTeam' for key 'journal_settings_pkey'

What can I do? Is it possible that our OJS is now corrupted forever?


#11

Hi @filipi,

Did you try to re-run the upgrade on your OJS after the first upgrade failed? A failed upgrade leaves the database in an inconsistent state, so you’ll need to restore from backup between attempts.

Regards,
Alec Smecher
Public Knowledge Project Team


#12

Hi, thanks for your message. I actually solved it by deleting the wrong entry in the database and hiting “update” again on the install screen. It updated smoothly after that.


#13

Hello,

I’m having the same issue

Upgrade failed: DB: Duplicate entry ‘0-1’ for key ‘citations_submission_seq’

@filipi, what key did you delete? When I tried to go into phpmyadmin, I don’t see what should be deleted to get the upgrade to work.


3.1.0.1 to 3.1.1 upgrade problem
#14

Hello,

I was able to get the upgrade to work, but now when I log in, the submissions queue is empty. Is there a way to resolve this issue?


#15

Was the update process successful?
If no, it’s better to try it again from the back-up. If yes, what errors do you see in the PHP error log?
Also, you can try to clear the template cache after an update (one of the previous updates involved some changes in the submission list handling).


#16

Greetings,
I was able to get it working by renaming the folder and then running the upgrade via the command line. Somehow that worked. Now I’m getting other errors when trying to do simple operations.
Clearing the template cache enabled me to see the submissions, but now when I try to delete an incomplete submission, I get:
##api.submissions.unknownError##

I see the following in the error log:

[Sun Jul 01 03:24:09.049380 2018] [access_compat:error] [pid 1459078:tid 139769879181056] [client 41.242.138.24:50964] AH01797: client denied by server configuration: /home/laghana/public_html/gjl/index.php, referer: https://laghana.org/gjl/index.php/gjl/submissions
[Sat Jun 30 21:20:39.881250 2018] [access_compat:error] [pid 1459078:tid 139769778468608] [client 41.242.138.24:61516] AH01797: client denied by server configuration: /home/laghana/public_html/gjl/index.php, referer: https://laghana.org/gjl/index.php/gjl/submissions
[Sat Jun 30 21:20:02.724586 2018] [access_compat:error] [pid 1458994:tid 139769778468608] [client 41.242.138.24:61498] AH01797: client denied by server configuration: /home/laghana/public_html/gjl/index.php, referer: https://laghana.org/gjl/index.php/gjl/submissions
[Sat Jun 30 21:19:06.952191 2018] [access_compat:error] [pid 1459022:tid 139769812039424] [client 41.242.138.24:61475] AH01797: client denied by server configuration: /home/laghana/public_html/gjl/index.php, referer: https://laghana.org/gjl/index.php/gjl/submissions
[Sat Jun 30 21:08:48.410552 2018] [access_compat:error] [pid 1322501:tid 139769879181056] [client 41.242.138.24:61215] AH01797: client denied by server configuration: /home/laghana/public_html/gjl/index.php, referer: https://laghana.org/gjl/index.php/gjl/submissions
[Sat Jun 30 20:58:37.001061 2018] [access_compat:error] [pid 1322321:tid 139769795254016] [client 41.242.139.36:60902] AH01797: client denied by server configuration: /home/laghana/public_html/gjl/index.php, referer: https://laghana.org/gjl/index.php/gjl/submissions
[Sat Jun 30 20:19:26.952107 2018] [access_compat:error] [pid 1322563:tid 139769770075904] [client 41.242.139.36:59713] AH01797: client denied by server configuration: /home/laghana/public_html/gjl/index.php, referer: https://laghana.org/gjl/index.php/gjl/submissions
[Sat Jun 30 20:19:20.569848 2018] [access_compat:error] [pid 1323211:tid 139769837217536] [client 41.242.139.36:59711] AH01797: client denied by server configuration: /home/laghana/public_html/gjl/index.php, referer: https://laghana.org/gjl/index.php/gjl/submissions
[Sat Jun 30 20:19:13.870707 2018] [access_compat:error] [pid 1323165:tid 139769879181056] [client 41.242.139.36:59708] AH01797: client denied by server configuration: /home/laghana/public_html/gjl/index.php, referer: https://laghana.org/gjl/index.php/gjl/submissions
[Sat Jun 30 20:19:09.581726 2018] [access_compat:error] [pid 1323165:tid 139769879181056] [client 41.242.139.36:59708] AH01797: client denied by server configuration: /home/laghana/public_html/gjl/index.php, referer: https://laghana.org/gjl/index.php/gjl/submissions
[Sat Jun 30 20:19:02.380912 2018] [access_compat:error] [pid 1322321:tid 139769828824832] [client 41.242.139.36:59705] AH01797: client denied by server configuration: /home/laghana/public_html/gjl/index.php, referer: https://laghana.org/gjl/index.php/gjl/submissions
[Sat Jun 30 20:18:53.010821 2018] [access_compat:error] [pid 1322501:tid 139769744897792] [client 41.242.139.36:59702] AH01797: client denied by server configuration: /home/laghana/public_html/gjl/index.php, referer: https://laghana.org/gjl/index.php/gjl/submissions
[Thu May 31 11:27:58.422652 2018] [access_compat:error] [pid 30501:tid 140259102799616] [client 66.249.66.156:38446] AH01797: client denied by server configuration: /home/laghana/public_html/gjl/lib/pkp/plugins/generic/acron/error_log

Also Masthead and Issue Data do not display when I click them. I’m definitely regretting my “upgrade” right about now as I have an active journal in production and these issues are pretty debilitating.


#17

Also, the site only works using PHP 5.6 or lower. When I go to 7.0 or 7.1 using the MultiPHP Manager in CPanel, the site tries to load and then, ultimately, returns a 500 error. I’m sure these issues are interrelated, but I am not clear on how to resolve them. Any assistance would be most appreciated.


#18

Any assistance with this case would be most appreciated.


#19

Hi @akyeame,

Those client denied by server configuration messages are coming from Apache, not OJS, and I suspect you’ve got some rules there that are interfering with OJS. See e.g. https://wiki.apache.org/httpd/ClientDeniedByServerConfiguration.

OJS should work with PHP7.0 and 7.1, but you may need to change your database driver in config.inc.php from mysql to mysqli.

Regards,
Alec Smecher
Public Knowledge Project Team


#20

Hi @asmecher,

I appreciate the response.
I tried adding this to the .htaccess

<Directory /var/www/gjl.laghana.org>
Order allow,deny
Allow from all

When I did so, it left me with a 500 error. The journal is located at https://gjl.laghana.org
Is there any way to track down what rules may be interfering and how to resolve it? Masthead and Issue Data are not working.

Changing the database driver to mysqli did the trick and now I’m running PHP 7.1, but the above problems still persist.

Again, I appreciate the assistance.