[OJS 3.1.1.2] Sword plugin not installing due to permissions

I first installed it manually and it didn’t work (as mentioned in the previous comment). I’m now trying to install it using the Plugin Gallery in OJS and it shows me this message:

“Plugin was not successfully copied. This may be a permissions problem. Please make sure that the web server is able to write to the plugins directory (including subdirectories) but don’t forget to secure it again later.”

My plugin directory inside the ojs installation have permission 0777 as well as every sub directory, my php server api is “Apache 2.0 Handler”, do you know how can I fix this error?

Hi @inthemist,

Is it possible that your manual installation of the plugin is getting in the way? Make sure you remove that before you try installing the plugin via the plugin gallery.

(Note that 777 permissions are never safe to use – make sure you set these back to something less permissive once you’ve finished tinkering with plugin installations.)

Thanks,
Alec Smecher
Public Knowledge Project Team

Hi,

we also have this problem. We first only removed the manually installed plugin and then completely removed OJS and installed it in a fresh environment, but the error still occurs.

Thanks for helping,
Kathleen

Hi all,

Please try installing the plugin again – I’ve adjusted a detail about the build and the new copy is available in the plugin gallery.

Regards,
Alec Smecher
Public Knowledge Project Team

The plugin now installed correctly thanks a lot, will proceed to test it.

Hi all

I would like to know if anyone could test the plugin. I was receiving a http status code 0. So, I change the code in /ojs/plugins/generic/sword/libs/swordappv2/swordappclient.php for it to print the url and it was blank, I had to change the variable $swordDepositPoint in ojs/plugins/generic/sword/SwordImportExportPlugin.php manually and now I’m receiving an status code.

I think that the url is not getting imported from the settings to the plugin.

(Sorry if this is not the correct place to post this, not sure if I had to start another topic)

Thanks!

Hi @inthemist,

Can you clarify where exactly you changed the code and what change you made, and what version of the plugin you’re using?

Thanks,
Alec Smecher
Public Knowledge Project Team

Hi

I originally tried it in the 1.0.0.0 version of the plugin but I tried it again in the 1.0.1.0 version. I had to change the line 183 in SwordImportExportPlugin.inc.php, instead of swordDepositPoint I wrote the adress of the deposit point.

When running it without changes, even when I added a deposit point url in the Sword Plugin settings , the $sac_url variable of the deposit function (line 55 in swordappclient.php) was left null.

Hi @inthemist,

Are you sure you chose the right deposit point type when configuring things? Depending on what type you choose, the URL should either be a service document URL, or a specific deposit point.

Regards,
Alec Smecher
Public Knowledge Project Team

@kneumann @inthemist Please guide how can i install this plugin please guide complete method our Current version is 3.1.1.4. This is my previous trail with PKP Forum team SWORD Plugin Not installing

I discuss with my web hosting company and they have no idea. You please guide.