OJS - Email template customization

Hello there,

Upon declining or accepting a submission, we’re given the option to send the author(s) an email notification of the decision made about the submission. We’d love to start using this feature, however we’d like to be able to customize the default email currently set up.

Instead of having to copy and paste our desired template onto the body of the email notification, it’d be great if we could change the default message altogether. Is there some way to do this in the Settings?

Any input would be greatly appreciated.

Did you check Settings > Workflow > Emails > Editor Decision Accept (blue triangle) > Edit Email

Hmm, for some reason, I am unable to see any blue triangles that say “Editor Decision Accept.” The only options I have to edit is “Signature” and “Bounce Address” (as seen in the screenshot below). Perhaps a bug in the system? As a journal manager in OJS, I assume this should be visible?


Something is wrong, you should see a listing of all email templates above the Save button. See:

When you enter that page, are there any errors visible in the php error_log or your browser’s javascript console?

I do see a couple of errors:

I’m unsure as to how to fix these however. This is in Firefox. I’ve tried using OJS in Chrome to see if the browser made a difference but no luck, it was the same result. Is there some sort of diagnostic I could run?

I suggest you go to the settings page, open the javascript console, clear any errors visible there and then try to reload the page and see what appears in the console log. You have errors related to other webpages there now.

Also you will need to see the php error_log as well, probably the reason why the listing is not appearing is easier to determine based on the errors visible there.

I have not seen a similar problem before, maybe @asmecher has (also he will be awake longer since it is 9 PM in Finland now :D)

Hi @canlitreviews,

I believe this is caused by custom email templates that contain spaces in their keys. I can’t recall precisely but I believe this used to be allowed in OJS 2.x but is not in 3.x. I’d suggest changing the email keys in the database to use _ instead of blank spaces.

Alec Smecher
Public Knowledge Project Team

@ajnyga I’ve cleared the errors in the console and refreshed the page but nothing changed. How could I go into the php error_log? I’m assuming Tools > Web Developer > Web Console isn’t where I should be going?

@asmecher Fingers crossed this is what needs to be changed. How can I change the email keys in the database?

Hi @canlitreviews,

Check in the following tables for the email_key column:

  • email_templates
  • email_templates_default
  • email_templates_data
  • email_templates_default_data

Alec Smecher
Public Knowledge Project Team

Where can I find the email_key column? Should I still be in console while viewing the Settings page?

you need to access the database using for example phpmyadmin or any other database client available for you from your service provider.

@ajnyga @asmecher Since I don’t have access to the database on my end, I contacted our university’s library as they are the ones who can go into the back end of OJS. They’ve now fixed the error and updated the email_key values. Apparently, the error was caused by these values being used verbatim in a jQuery selector.

Anyhow, all is finally well! Thank you for your help.

1 Like

I am Venkat. I have one doubt Fridends.
I have assign file to copy editor. I need acknowledgement mail to my requested id . how to set this Copyediting Request template or anyother way.

Please help