OJS 3.1.1.2 - Decline Submission Button is missing


#1

Hi,

I’m using OJS 3.1.1.2 and a Manager have problems to decline a submission.
In some cases the Decline Submission Button is missing and in other cases the Decline Submission Button is missing is shown.
This user has the following roles: Journal manager, Journal editor, Copyeditor, Author, Reviewer and Subscription Manager.

Decline Submission Button is missing:

Decline Submission Button is shown:

Any ideia?

Regards.
Tarcisio Pereira.


#2

Hi @Tarcisio_Pereira,

One difference between those 2 submissions is one is at the submission stage and the other is at the Production stage. However, the one at the submission stage should still have all 3 options available. Are all submissions for your journal at the submission stage only showing the option to “send to review?” Or is this the only one?

Thanks,
Amanda Stevens
Public Knowledge Project Team


#3

Hi @astevens

Not all submissions at submission stage, this case only and only for this specific user. For me as site administrator is showing all 3 options available.

Regars,
Tarcisio Pereira


#4

Hi @Tarcisio_Pereira,

Thanks for the further information. Can you post a screenshot of the editorial history of the submission - the one that you can only see the Send to Review button for? I want to see if there is anything unusual in the history.

Thanks,
Amanda


#5

Hi @astevens

The print:

Regards,
Tarcisio Pereira


#6

Hi @Tarcisio_Pereira,

Can you go to Roles and click Edit below the Editor de Revista role and check if “This role is only allowed to recommend a review decision and will require an authorised editor to record a final decision” is checked off? That would explain why the user can only send the submission to review and can’t make a decision to accept or decline the submission. Although the user has multiple roles, if they have been assigned to the submission in the Editor role, the restrictions of that role may apply.

Best,
Amanda Stevens
Public Knowledge Project Team


#7

Hi @astevens

This options is uncheck now and now it’s working again.
But I don’t know if it was disable when I opened this issue.
Perhaps and journal manager change it.

Any way, thank you a lot.


#8

Hi @Tarcisio_Pereira,

I’m happy that worked! Thanks for letting me know.

Best,
Amanda


#9

could you tell me in which part of the control panel did you solve this … thanks


#10

Hi @revistageon

I don’t know how it was solved.
Someone in the journal did something and it worked again.
I take care of a portal with 185 journals, I do not follow them all closely.

Regards,
Tarcisio Pereira.