[OJS ] Plugin Citation Style Language prints "How Cite" info without comma and space

Hi everybody

I have a strange behaviour with the Citation Style Language Plugin for my OJS, the issue is the following:

In some cases the section How Cite prints the lastname and the initial letter of the firstname without the comma symbol and space between them as show in the following screenshot


In other cases the same section is printed in the right way as show in the following screenshot


I have reviewed the metadata forms where introduced that information for the cases where the how cite information is not printed right, searching some hidden characters and I have deleted and wrote them manually, but the behaviour is the same. It’s the first time I have seen this behaviour with this plugin. Someone has the same issue?

I hope someone could help me with this trouble.

Good afternoon.

Could you solve this?
I have the same problem in an OJS 3.1.2-4

I also have the same problem with citation in an Ojs 3.1.2-4. Is there any solution for this problem?


We have the same problem with citation in an Ojs 3.1.2-4.
I think it has been going on for several sub-versions but that we have just noticed it.
The section How Cite prints the lastname and the initial letter of the firstname without space between.

Could this problem be identified and planned to be resolved ?

Best regards.

Hi all,

If some citation formats correctly format the name, and others don’t, then the problem is likely to be in the CSL files that are included with OJS. We use the third-party CiteProc-PHP library along with a selection of commonly-used CSL formats in plugins/generic/citationStyleLanguage/citation-styles/. You might try checking the support resources for that library to see if more information is available there.

Alec Smecher
Public Knowledge Project Team

We also faced same problem.

It found out that this problem caused by php-xml extension on php7.3. To solve this problem we change the php to php7.2 and problem is solved. We also have tried this on nginx or apache server and the problem is still emerge if we uses php7.3.

Make sure you have installed on the php7.2 these extension :
php7.2-mbstring php7.2-xml php7.2-zip


Hi @asmecher, Hi everybody,
If it’s a problem caused by php-xml extension on php7.3 and that we can’t change the php to php7.2, who do we have to ask to solve the problem on php7.3 ?
Best regards.

Hi @asmecher, Hi everybody,
I saw the bug had been already reported on the Issue Tracker of citeproc-php project.
Best regards.

Hi @NateWr,

We are using OJS 3.1.2-4 with PHP 7.3.
While waiting to install the OJS 3.2.1 version with submodule citationStyleLanguage updated, what can we do on our current version to fix the bug?
Could we just replace composer.json and composer.lock files in submodule citationStyleLanguage as mentioned in Update citeproc-php to 2.2.0 to fix PHP 7.3/4 issues ?

Thanks in advance for your anwser.
Best regards.

HI @hcl,

Probably not. That’s a change in a dependency so if you’re running off the built release packages that we release, just making that change won’t fix it.

If you’re running from the git repository and your technical support knows how to run composer update, they can fix it by applying the changes to the composer.json file and then running composer update.

Hi @NateWr,

Thanks for your quick answer.

Kind regards.

Thanks everyone!
We have updated 2 OJS websites to and also updated PHP to 7.4. So after this we got the same problem in Citation Style Language Plugin.
This has been fixed by returning to PHP 7.2 for one site and PHP 7.3 for another one site…