OJS 3.0 Improting İssues with NAtive XML Guideline

ojs
xml

#1

I am new to OJS and I am using OJS 3.0.2 and trying to import submissions but I can’t seem to get a handle of it.I would really love it if you could direct me to a documentation or clarify the steps I need to take to import them(preferably Native XML)


#2

Hi @Abraham27

If using native XML import, you would have to construct an appropriate XML for article(s) or issue(s). You can find the XML schemas here:
https://github.com/pkp/pkp-lib/blob/master/plugins/importexport/native/pkp-native.xsd
https://github.com/pkp/ojs/blob/master/plugins/importexport/native/native.xsd
The later one includes the first one.
And here is an issue XML example: https://github.com/pkp/ojs/blob/master/tests/data/60-content/issue.xml
When you have the valid XML, you can upload it as journal manager > Tools > Import/Export > Native XML Plugin > Import.
Unfortunately, I think we do not have the documentation about the native import/export in OJS 3 yet, but eventually, the old docuemntation (for OJS 2.4.x) could help you: https://pkp.sfu.ca/wiki/index.php/Importing_and_Exporting_Data. Just be aware that the XML format totally changed!

The other possibility to import articles more quickly would be to use QuickSubmit plugin, s. https://github.com/pkp/quickSubmit. This plugin is also listed in the plugin gallery in the newest OJS 3.0.2.

Best,
Bozana


#3

Dear @Bozana and community,

I face the same challenge: importing article (and issues) via the xml import plugin.
I created a sample xml for importing an article without embedded files. Everything seems to work, however, the error occured “Unknown section”. I have chosen “Review”, since this is a section, that was created within the journal setting. But the error still occurs.
Below you see the sample xml. Do you have any idea to fix this issue?

Thanks and cheers
Sleipnir

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE issue PUBLIC "-//PKP//OJS Articles and Issues XML//EN" "http://pkp.sfu.ca /ojs/dtdsnative.dtd">
<article xmlns="http://pkp.sfu.ca" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" locale="de_DE"  date_submitted="2018-01-12" date_published="2015-05-06" section_ref="Review" seq="2" access_status="0" xsi:schemaLocation="http://pkp.sfu.ca native.xsd" stage="production">
<id type="internal" advice="ignore"></id>
<title locale="en_US">English Title</title>
<title locale="de_DE">Titel in anderer Sprache</title>
<abstract locale="en_US">English Abstract</abstract>
<abstract locale="de_DE">Abstract in anderer Sprache</abstract>
<copyrightHolder locale="en_US">The Author(s)</copyrightHolder>
<copyrightHolder locale="de_DE">Die Autoren</copyrightHolder>
<copyrightYear>2018</copyrightYear>
<keywords locale="en_US">
    <keyword>First English keyword</keyword>
    <keyword>Second English keyword</keyword>
</keywords>
<keywords locale="de_DE">
    <keyword>Erstes Stichwort</keyword>
    <keyword>Zweites Stichwort</keyword>
</keywords>
<authors xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://pkp.sfu.ca native.xsd">
  <author include_in_browse="true" user_group_ref="Author">
    <firstname>Max</firstname>
    <lastname>Mustermann</lastname>
    <affiliation locale="en_US">English affiliation</affiliation>
    <affiliation locale="de_DE">Institution</affiliation>
    <country>DE</country>
    <email>author.1@email.com</email>
  </author>
</authors>
<issue_identification>
  <volume>70</volume>
  <number>12</number>
  <year>2018</year>
</issue_identification>
<pages>400-402</pages>
</article>

#4

Hi Abraham,
I have just gone through the process of importing back content and I had a few problems too. Eventually I added missing data manually, but I would still like to create the perfect file.
This is what happened to me: Initially, as I was importing articles in Italian, some data was captured with the tag <“it=IT”>. As an example, consider the field TITLE: the import resulted in the information actually being displayed on the public site, but not populated in the metadata screen; however, when I tried to enter the information in the metadata screen, I kept receiving the error that the title was mandatory. Same for other fields like discipline and keywords. I changed to tag to <“en=EN”> and it went much better: I have managed to import content smoothly, but I found that some data are not imported, like the country for each author, the DOI for each article and the language (in the additional refinements).
Once the content was imported, correctly in its issue, I had to go into each article, define APC and assign it to an issue (even if it was displayed in it), then go through all articles to make them appear in the correct order.
I am not very experienced with OJS, but I hope my process can help you. I can send you the file we created if you want, so that it speeds you up a bit.
Let me now how you get on, it will be good to exchange experiences.
Regards,
Lucia


#5

Hi @Sleipnir,
I think you should use section abbreviation in your section_ref attribute, i.e. you can see what is the abbreviation of your section “Review” and enter that for that attribute. I think this will solve that error message.

Hi @lsteele,
The languages should actually be correctly imported. What OJS version are you using?
The journal has to have that language enabled for submissions and forms, and the article locale attribute and the locale attributes of other metadata elements have to correspond and be correct (e.g. locale=“it_IT”). Else it should work fine…

Best,
Bozana


#6

Hello Bozana,
thank you for getting back to me. It is interesting to know this: I had in fact NOT enabled the locale when I imported my articles, this is probably the reason for the problems I found.
I could actually get round reasonably well and completed my import successfully.
Have a good day!
Lucia


#7

Thank you @bozana! This works!!! The article was successfully imported.