OJS 3.0 don't Install in Windows 10


I tried to install OJS 3.0 in Windows 10 but it does not work. When I click the install button Open journal systems does not do anything. I have installed a XAMP version 7.2.9. The installation parameters are fine, I had previously installed it in windows 7 , but in windows 10 it does not work for me …

Please try with the latest version of OJS.
Windows 10 itself should not be problem. if you use XAMPP and it is installed correctly that would be sufficient to install OJS.


Hi @Migue,

I am using OJS in windows 10 without problem. I have installed XAMPP. See snapshot below.
If you are stuck at any particular step, please write in detail.


best regards,


Download the latest version of the ojs (OJS Version .MI XAMP is version 7.2.9, it is installed without problems. When I click on the installation button it does not do anything. Below I send the configuration parameters on the page of installation.I do not know what I’m doing wrong !! … in Windows 7 install it perfectly!1 2 3 4 5

Hello Anup Acharya

Thank you for answering me. Check the forum, there I put some screenshots with the installation screen. The strange thing is that the installation button does not work for me …

Please put that MySQL driver is MySQLi.
I usually create database and user before installation.

1 Like

Nothing … create a BD and change the MySQL driver for MySQLi…and nothing … the button does not work … it loads the page and does nothing … it’s as if the submit fails

Hi @Migue,
I have some suggestions, please try them.

1.  client_charset = utf-8; connection_charset = utf8; database_charset = utf8
2. file settigs: Is your file folder not in the XAMPP.s folder? I have no idea if it works that way. If it was working the same way in your windows 7, then it should work. Also, note the the windows path should be forward slash.
3. Your database driver is MySQL. Try with MySQLi.
4. If all these do not work, your make your database in the localhost/phpmyadmin and then add those details in the respective field during set-up and un-tick 'create new database'

I hope you would succeed.
In case you still fail to successfully install, you need to see your php error_log. In my case it is in “\xampp\apache\logs\error.log”

Best regards,

I have tried everything … the only thing I have left to think is that it is a problem of permissions in windows 10 … but I am administrator in my PC … I do not understand !!!

Have you run your XAMPP as an administrator?

Edit: Right click and run it as an administrator.

Yes … nothing more happens … some idea?

Is it necessary to have NodeJs installed?

Did you enable in your php.ini that php creates error_log file?