OJS 3.0.2 Not receiving emails

I run a journal on OJS 3.0.2.

After running some test submissions, I noticed that Authors do not receive notifications onces they submint an article, and most important, Reviewers do not receive notifications once they assigned. If I go to Submissions → All Active → “tested Article” → More Information → History, I can see that notification/reminder emails were sent (from journal editor account).

Then I sent a Reminder email for the same Reviewer of the same “tested Article”, but from Admin account, and the email was delivered.

The accounts I tried to send notifications had roles of Journal Editor, Author, Reviewer and reader.

Can you please help me to find out the problem?

thank you

Hi @Mila_Simakova,

Do you have access to the email sending logs on your server (if not using smtp in config.inc.php) or to the delivery logs on your SMTP server (if you’re using one)? It’s possible that some messages are not getting delivered e.g. because the server thinks they’re spam.

Alec Smecher
Public Knowledge Project Team

Yes, I have access to the tested mailboxes.
I didn’t find sent emails in the spam box. The same email address didn’t receive emails from author’s and manager’s accounts, but received an email from admin account.
Can you please advise how do I check my delivery logs on SMTP server?

Hi @Mila_Simakova,

You’ll have to ask your service provider whether or not you have access to these.

Alec Smecher
Public Knowledge Project Team

Thank you
The problem is solved

How did you solve the problem ?? I have the same issue

Well, I’m not sure which of the following steps had helped me.
I found out that the problem is “Principal Contact” email address. Apparently it’s a common problem and it’s described HERE .
I found This Topic and followed their advises.
First of all I reinstall OJS (which could have been the resolution), then I set SMPT to On by removing ; before some of the lines (see my post in the topic), and set “Principal Contact” to the e-mail which matches the domain (Journal settings >> Contact >> Principal Contact ).
Hope it will help.