OJS 3.0.1 and Quick Submit plugin

Hello
i am a new user of Open Journal System, and i have a problem.

When i tried install QuickSUbmit (from de backend), system didn,t permit (it didn,t anything). The message that the system send me is: Command Tar is not available. Configure it correctly in “config.inc.php”.

After this, i installed QuickSubmit “manually” (uploading files). QuickSubmit is installed, but it don,t work correct. Backend of OJS tell me “can be updated”.
I try to update, but it dont work… Telle me the same message: Command Tar is not available. Configure it correctly in “config.inc.php”.

Then, my problem is that i don,t know how can a i configurate the file config.inc.php, with the purpose that QuickSubmit work.

QuickSubmit1QuickSubmit2

Please, if you can help me, i,ll be grateful.
Thanks!

PD: Sorry for my English, is not my languaje, but i hope you understand.

Hi @jruiz,

Your OJS installation probably doesn’t have file permissions set such that the web interface can install new plugins. It’ll attempt to put the plugin into plugins/importexport/quickSubmit (creating that directory in the process) – make sure that your file permissions allow OJS to do this. (There’s a FAQ entry on file permissions in this forum.)

Regards,
Alec Smecher
Public Knowledge Project Team

Hi @asmecher Thanks for your help

I checked permissions, and i think everything is ok.

I found command tar indfile config.inc.php, and it is there only 1 time. You can see in the screenshoot.

Tar

I think, maybe the problem is that i should add some command in the file config.inc.php but, as i told, is my first time with OJS, and i don,t know…

Many thanks

Hi @jruiz,

What is your server OS and SAPI (the way your web server and PHP interoperate), and what have you set your permissions to?

Regards,
Alec Smecher
Public Knowledge Project Team

I have the same problem but there is a work-around if you download the plugin from Github and put it in the right place (/plugins/importexport) using FTP . I would still like to get Tar working though.

I have installed ojs 3.1.2.1 july version (latest). And installed Quicksubmit plugin from the Gallery. But it doesn’t work, showing http 500 error. @asmecher please help.

Hi @samiraza28,

Check your PHP error log for details.

Regards,
Alec Smecher
Public Knowledge Project Team

Dear @asmecher Alec Smecher,

We are having the same problem when we are trying to use the quick submit plugin after installing ojs-3.1.2-1 . We are accessing it from the plugins gallery and when we do so then it gets stuck and nothing happens after that. Can you please help us with this? We have tried all the methods described here in this thread but it is not working.

Best Regards,

Hi @webuos,

Check your PHP error log for details.

Regards,
Alec Smecher
Public Knowledge Project Team

Dear @asmecher, We have checked it but there is nothing noteable that could help us with this issue. Is it possible for you to check this issue and help us resolve it if we provide the credentials to you?

Best Regards,

Hi @webuos,

I’m afraid that’s beyond the level of support I can provide here – but if you’re able to identify a message in your PHP error log, perhaps I can help further. (This may be helpful: How do I find my PHP error log?)

Regards,
Alec Smecher
Public Knowledge Project Team

image

Im tring to upload plugins then error showing

Hi @work_virus,

What version of OJS are you using? (Please include this in your posts.)

How have you configured your tar command in config.inc.php?

Regards,
Alec Smecher
Public Knowledge Project Team

quickSubmit_Crash-1 quickSubmit_Crash

Quick Submit Crashes on clicking “Import/Export”

Am using OJS 3.1.2.1

OJS Error Log:
PHP Warning: Declaration of CustomBlockPlugin::getBlockContext() should be compatible with BlockPlugin::getBlockContext($contextId = NULL) in /home/ajhseorg/public_html/plugins/generic/customBlockManager/CustomBlockPlugin.inc.php on line 134

Webserver Error Log
WebserverErrorLog

Hi @Kivos_Webmasters_ICT,

There is probably a “Fatal Error” further up in your log file; please check and see if you can find it.

Regards,
Alec Smecher
Public Knowledge Project Team

I have checked both log files to thier respective ends. Could not find a “Fatal Error”

Hi @Kivos_Webmasters_ICT,

When you say that the plugin crashes on hitting “Import/Export”, can you describe the behaviour further?

How did you install the plugin?

Regards,
Alec Smecher
Public Knowledge Project Team

First, quickSubmit was not part of my OJS 3.1.2.1 installation. It was not part of the installed plugin list

So, I download it from: GitHub - pkp/quickSubmit

Extracted it to: plugins/generic/quickSubmit (with the folder name: “quickSubmit”)

I logged into my OJS 3 dashboard and when to plugins.

I saw it listed among the plugins,

When I click on the “Import/Export” under it, I get the JSON Pink Color Screen which I earlier attached above (kindly scroll up to check my previous messages).

This is obviously an error, as it does not open the “Import/Export” page where I could upload my articles for quick publication into my issue.

I hope my explanation is clear to get an understanding of my issue.

Hi @Kivos_Webmasters_ICT,

You’re probably running a version of Quick Submit that is not compatible with your OJS. The best way to install the plugin us using the Plugin Gallery; this will take care of installing the right version. If you can’t use that, make sure you download the right version of the plugin from the Releases area of its GitHub repository.

Regards,
Alec Smecher
Public Knowledge Project Team