OCS - Version.xml not found in plugin directory

Hi, I’m currently working on a plugin for OCS. As I understand the current architecture, rather than coping your source to the relevant directories installation should be done via the plugin manager so said plugin is registered correctly.

The issue I have is that everytime I try to install my plugin I get;

Errors occurred processing this form:
Version.xml not found in plugin directory

I’ve check my .tar file and I have version.xml where it should be, I’ve also tried another third-party plugin with the version xml in place , unfortunately I still get the same result,

I’ve check the permissions on the server and for the purpose of testing opened every thing up (i,e, chmod 777 all the way) so I don’t believe it is a permission issue.

I’m using OCS

Any thoughts would be appreciated, thanks in advance.

Hi @Darren_Moore,

I suspect your plugin isn’t packaged in a way that OCS expects. Try putting all the plugin files inside a directory named after the plugin, and archiving that directory. (For example, to create a plugin this way using the TinyMCE plugin, you’d use…

cd plugins/generic
tar czf tinymce.tar.gz tinymce

If you don’t intend to distribute the plugin, but just want it to be registered with OCS, then you don’t need to install it this way; just run the upgrade script (php tools/upgrade.php upgrade) to do so. Back up your database first, just in case your OCS is in an odd state e.g. from a failed previous upgrade.

Alec Smecher
Public Knowledge Project Team


That worked a treat - I can now stop banging my head against the wall!

Thanks again