OCS - hide supplementary files from reviewers


We are in the phase of full paper review for a conference. We have completed the abstract review phase.
When I assign a reviewer to a paper and send them the request, the reviewer is able to see the RV version of a paper as well as supplementary files.
I’m unable to uncheck “Present file to reviewers” checkbox (it’s grayed out) and hide the supplementary files from the reviewers (some of them contain data that would compromise the blind review process).

I’m using OCS version 2.3.5


Never mind my question.

This problem that I described was at the Paper review page of a submission.
If I go to Summary page I’m able to edit each individual supplementary file and un-check the box “Present file to reviewers (without metadata), as it will not compromise blind review.”

Kind regards,


1 Like


I’m having the opposite problem. The reviewer can’t see the supplementary files. If as Director I look at the PAPER REVIEW page there is the checkbox next to “Present file to reviewers []” but its greyed out and disabled. The reviewer has accepted the review and can see one file OK as that one file is not a supplementary file.

How to I set this so reviewers can see the supplementary files?


Ah :slight_smile:

If I go to SUMMARY and edit each individual supplementary file and select:
“[ ] Present file to reviewers (without metadata), as it will not compromise blind review.”
then the reviewer can see the files.

I need to change this to be the default for all supplementary files for all papers. I already have set “Reviewers will have access to the submission file only after agreeing to review it.” and would like to keep that setting still.

I see the value that decides that reviewers have access to the supp files is set in the table paper_supplementary_files and the field show_reviewers =1 (for show) or NULL (for no show).
I could write a script that would change all these each night and set any with NULL to 1

But is there a setting in the OCS interface for this?


Hi @MikeL,

There’s no setting to change the default, but you could cause all new supplementary files to have that default by editing classes/submission/form/SuppFileForm.inc.php in the initData function.

Alec Smecher
Public Knowledge Project Team

Okies I see its set here like this:
showReviewers' => $suppFile->getShowReviewers()==1?1:0
so I could change it to ==0?1:0
The ternary operator on the right of the ? I presume I leave the same?

What I had done to fix it was to write a bash script that ran each night and did this:
update paper_supplementary_files set show_reviewers=1 where show_reviewers is NULL;
That’s been working fine for a week but changing the default in the code is cleaner and a better way.


1 Like