OAI compatibility, OJS 3.1.1.2

We want to register our journal in OJS as OAI repository. The test mechanism from OCLC says that there is availability of system but that it failed testing OAI Support.
OAI in config.inc.php is set as “on”.
Please advise

It might help to try the BASE oai validator, it usually gives some details on results: http://oval.base-search.net/

1 Like

Hi @vvucic

Did it list any failures i.e. tell what is/could be the problem?

And yes, maybe you can evaluate the OAI with some other validators as well…

Best,
Bozana

@ ojsbsb sir how to resolve the issue if i see in

XML Validation

ERROR: Identify response well-formed but invalid: Element ‘{https://www.openarchives.org/OAI/2.0/}OAI-PMH’: No matching global declaration available for the validation root., line 6

ERROR: ListRecords response well-formed but invalid: Element ‘{https://www.openarchives.org/OAI/2.0/}OAI-PMH’: No matching global declaration available for the validation root., line 6

any advice will be appreciable.

thank you for your support

Hi @jain034567,

This is the same issue you posted over at FAILED: Testing OAI Support in Worldcat digital collection gateway - #3 by jesparza, correct? Please don’t post the same content multiple times; it clutters the forum.

Thanks,
Alec Smecher
Public Knowledge Project Team

I’m sorry and will not post another message, but i am facing the issues thats why i’m trying to find the solution. Kindly review the thread and do the needful
"Problem with OAI with new version of OJS repository 3.1.2.0"