No contributor's role options


I installed OJS using Softaculous from cPanel.

Everything works fine, until I submitted an article. When I added contributor to the article, I could not find the Contributor’s role options (see the pic below).

no contibutors role 01 when adding contibutor to article

Without choose an contributor’s role, no contributor can be added to my article. Without a contributor added to my article, OJS would not receive my article as a complete submission.

When I open my profile page, I realized that in the Role tab, there is no role options as my last OJS installation. FYI, I have installed OJS 3.1.x.x at another sub domain using Softaculous before.

no user role 02 at profile

Could any one help me, please…

I have looking for the error code at my error log. But, I could not find anything related. I think it’s because I am a newbie and not very familiar with OJS.



Hi @idoeb,

Are you logged in with an existing user account when you create the submission? Usually OJS will make that user the main contributor on the article, and then provide the option to add additional contributors. You can see and edit the roles assigned to a user in the left-hand menu under “Users & Roles” > Users > Edit User. I recommend checking the role assigned to the user in those settings and then trying the submission again.


Hi @kshuttle,

Thanks for your reply.

Yes, you are right. OJS automatically made me as the main contributor. But, actually I am not the contributor for the article. So I deleted my account from contributor list, and added another contributor. Unfortunately, the contributor’s role options did not appear so I could not choose it.

I did your suggestion and user’s role seems okay.
no user role 03

Hi @idoeb,

Do you still have the “author” role available for the journal? It should be one of the options under Users and Roles > Roles - with the permission level “Author.”

Hi @kshuttle,

This is the Roles tab at my dashboard:

no user role 04

And as you see, there is no “Author” role. I will add it manually and come back with the result.

FYI, the top six of roles are the default role which came with the Softaculous installation. The last one (Journal Manager 2) has been created by me.

Hi @kshuttle,

Thanks for your support. After added the Author role manually, now the contributor’s role options appear.

no user role 05

From that, I could followed the steps until the article has been published.

Hi @idoeb,

Great to hear that this resolved the issue.