Mysql 4.1 on ubuntu service 18.04 linux: how to install?

I recently made a topic about problem in the ojs-3.1.2 installation that redirects to the index.php file and I have not solved it yet. I installed ojs-3.1.2 based on the requirements of ojs-2.x.x (only php which was a newer version).

I have now found the requirements recommended for ojs-3.1.2 (

  • PHP &; = 7.0
  • ** MySQL = 4.1 ** or PostgreSQL = 9.1.5
  • Apache = 1.3.2x or = 2.0.4x or Microsoft IIS 6
  • Operating system: Any operating system that supports the above software, including Linux, BSD, Solaris, Mac OS X and Windows

My server is Ubuntu Linux from the Ec2 instance of Amazon Webservice, and mysql is the latest version (5.7). I have already removed this version of mysql, however, I can not install version 4.1 and found no tutorial in my language available on the internet.

When I access my browser to configure the installation page, the index.php file appears. I do not have much understanding about programming.

Can anybody help me???

Thank you very much in advance.

yourdomain/ojs-folder is the way to execute the installer.

What do you mean with index.php? The apache index? If you can post screenshots, it could be easier to help you.

  • Make sure you have installed the php packages.
  • Did you move the ojs folder to the var/www/html?
  • Did you give the permissions to the specific folders and files?

Hello, @sgarcia

So I extracted the ojs-3.1.2 folder to / var / www / html (I also tested with / var / www). I gave permissions to the ubuntu user. And the following permissions:

chmod + w -R public /
chown -R www-data cache /
chown -R www-data cache / t_cache /
chown -R www-data cache / t_config /
chown -R www-data cache / t_compile /
chown -R www-data cache / _db
chown -R www-data / var / ojs_uploads

When I try to navigate the installation panel, this index.php file appears. I did the procedure several times. I even deleted my AWS server and created it again. But the problem persists.

Ubuntu 18.04 is standardized with version 5.7 of mysql. According to the requirements of ojs-3.1.2, it has to be mysql 4.1. However, I can not change the version. I think this may be the problem (or not).

Note: I downloaded ojs-3.1.2 on windows 10 and downloaded via FilleZilla to the ubuntu puTTy command.

Ok, I will give you the way I made it work.

If you want my way to work on your machine, please delete your store folder and your ojs folder and start over again because I think you configured the owner of the files and I didnt do that to make it work.

  1. Install PHP and its packages.
  2. Create a ojs user with all the permissions in mysql.
  3. Put the OJS folder on /var/www/html/ ← here. So your way to access to it trought the web browser will be: yourdomain/ojs-folder.
  4. Move into the OJS folder, and give all the permissions to the follow files and folders with
    chmod 777 -R public/
    chmod 777 -R cache/
    chmod 777 -R cache/t_cache
    chmod 777 -R cache/t_config
    chmod 777 -R public/t_compile
    chmod 777 -R cache/_db
    chmod 777
    chmod 777
  5. Create the ojs files folder in /var, and give it the permissions with chmod 777 -R ojs-files/
  6. Now via yourdomain/ojs-folder you should access to the web installer.

I will wait for your answer. Good luck.

I’m extracting ojs-3-1-2 again to compare this to your tip. In the meantime, do I confirm if this chmod 777 permission is secure? They say the site is vulnerable with this permission.

I also saw that 777 is not that safe. But it was the only way I made it work.
Following the instructions, it could work just wit 666.
I am still thinking about to modify those permissions but atm I will stay with 777.

Btw, I have tried all the ways with this installation(750,755,0750 and 0755), first time setting up a website in a server.


Now finally the index.php file is gone, but the page is blank.
I did the following procedure

1 - updated php packages:
sudo apt install libapache2-mod-php
sudo apt install php-curl
sudo apt install php-xml
sudo apt install php-mysql

2 - gave permissions in mysql with the following command:
GRANT ALL PRIVILEGES ON *. * TO ‘user’ @ ‘localhost’;

3 - With root user on the ubuntu terminal, extract the folder ojs-3.1.2 in var / www / hmtl / and I edited the folder name for “journal”.

4 - I changed the permissions of the page “newspaper” with the following commands:
sudo chown -R ‘user’: www-data / var / www / html /
sudo find / var / www / html -type d -exec chmod 2770 {} +
sudo find / var / www / html -type f -exec chmod 0770 {} +

5 - I used the tags that you made available:
chmod 777 -R public /
chmod 777 -R cache /
chmod 777 -R cache / t_cache
chmod 777 -R cache / t_config
chmod 777 -R cache / t_compile
chmod 777 -R cache / _db
chmod 777
chmod 777

When I connect to the browser with, it loads, but the page is completely blank.


I don’t understand your fourth step. What is that? I didn’t touch those commands