My Journal deposits are not shown in PKP PN Plugin

Dear All,

I have installed the PKP-PN plugin. It shows the “Network Status: The PKP PLN can accept deposits from this journal”. My deposits are not shown in the list. I installed the plugin a year ago. I am using Open Journal Systems 3.3.0.13.

Thank you in advance.

C. Srinivasan
xlescience.org

Hi!

Before I try to help you, can you upgrade your installation to the latest OJS 3.3 and also upgrade the plugin? A lot of fixes have been done to both regarding the Preservation Network, so it’s possible that it will be enough to fix your problems.

Best,
Jnas

Dear @jonasraoni

I have already upgraded the plugin. The current OJS version is 3.3.0.13. I tried to update OJS 3.4.0.5. But I encountered another problem. I have attached the image below.

Kindly let me know how to overcome this issue as well as PKP PN
Thank you in advance.

Is this upgraded journal online somewhere? I haven’t seen this problem before, so I’m curious to take a look. Perhaps clearing the data cache on the “Administration” menu will solve the problem:

About the plugin… Please take a look in the folder {$files_dir}/scheduledTaskLogs/, and check if you have files starting with PKPPNDepositorTask-.

If not, then looks like your system is not running the scheduled tasks, I’d recommend to enable the Acron plugin (if it’s already enabled, there’s an option to reload the tasks, see the image below).

image

If you have such files, send me the content of the newest, and also the entries of one day ago from the error.log file of your server (the plugin runs once per day, so the content of one full day is enough).

Best,
Jonas Raoni

Dear @jonasraoni

Thank you for your support.
After deleting the data caches and upgrading OJS completed successfully.

Thank you

Dear @jonasraoni
There was no such file ( PKPPNDepositorTask-) inside the folder.
As per the instructions, I enabled the Acron plugin and reloaded the scheduled tasks.
Now I can see the ( PKPPNDepositorTask- ) file in the folder (/scheduledTaskLogs/).
The entries in the files are given below.

[2024-06-28 07:00:55] https://xlescience.org
[2024-06-28 07:00:55] [Notice] Task process started.
[2024-06-28 07:00:55] [Notice] PKP Preservation Network Processor
[2024-06-28 07:00:55] [Notice] Depositor processing for INTERNATIONAL JOURNAL OF ADVANCES IN SIGNAL AND IMAGE SCIENCES.
[2024-06-28 07:00:55] [Notice] Getting service document.
[2024-06-28 07:00:56] [Warning] The PKP PN terms of use have been updated. agreement with new terms is required to continue depositing.
[2024-06-28 07:00:56] [Notice] Pruning orphaned deposits.

I checked all the terms of use (PKP PN Plugin) and saved it.
Now also, my deposits are not shown in the list.

Thank you in advance.

Great! About the plugin, you need to access its settings, accept the terms, then click on save:

image

Best,
Jonas Raoni

Dear @jonasraoni

I already accepted the terms and clicked the save button.
My deposits are not yet shown in the list.

Thank you in advance

Hi!

The plugin does it work once per day, so you need to wait one day.

You also can force the task to run again. You’ll need to update the table scheduled_tasks in the database, there should be an entry with the class_name = APP\plugins\generic\pln\classes\tasks\Depositor, you can set the date to the past (e.g. 2000-01-01), then the task should be executed after accessing the site (if you’re using the Acron plugin). If you’re using the standard CRON to run the tasks, then you’ll need to run this in the command line php tools/runScheduledTasks.php at the base application folder.

Then if it doesn’t work, let’s restart here: My Journal deposits are not shown in PKP PN Plugin - #6 by jonasraoni

Best,
Jonas Raoni

Dear @jonasraoni

Thank you for your great support.
My deposits are shown in the list now.

Need to resubmit?

Thank you

No, you just need to wait, it can take some days to complete. You just need to resubmit if something goes wrong.

For example, the server will scan if there are viruses on the uploaded files, if yes, the deposit will fail. Then you could remove the bad files and resubmit.

Best,
Jonas Raoni

Dear @jonasraoni

Thank you for your great support.
After upgrading the OJS, I just now see the two below errors in my website.

  1. In 'How to Cite; the author’s names are not retrieved.
  2. In Downloads, For all papers, the graph shows 0 downloaded for Feb 2024. I would like to know where the number of downloads stored in the database.

(For Example: https://xlescience.org/index.php/IJASIS/article/view/129)
Kindly find the attached image file

Thank you in advance.

Tagging @bozana for help over these topics.

Best,
Jonas Raoni

Hi @srinivasanchelliah

You are using OJS 3.4.0.5 now, right?

  1. Is your CitationStyleLanguage plugin configured – the ‘Contributors’ section in the plugin settings? (To be find under Settings > Website > Plugins > Generic Plugins > Citation Style Language > Settings.).
  2. The numbers are in the table metrics_submission. Eventually you have the opportunity to compare the old (before the upgrade) DB table ‘metrics’ with the new DB table ‘metrics_submission’?
    Were the numbers OK earlier i.e. before the upgrade?
    Have you noticed any errors/warnings during the upgrade?

Thanks!
Bozana

Dear @bozana

Thank you for your support.

  1. A small modification in the plugin retrieves the author’s name correctly.
  2. Will check the data and let you know.

Thank you

Dear @bozana

I have not seen the “usageStats” plugin in my list after upgrading.
Kindly let me know how to install the above plugin?.

Thank you in advance.