Multilingual website with monolingual form fields for metadata

My journal’s website runs in two languages - English and Polish. In website settings tab English is primary locale, UI and forms are checked for both languages, but submissions are allowed only in English.
My problem is that I want to have only English fields (single) in submission form (metadata), but since the forms are also checked for Polish (we have to edit website content in both laguages) in submission form therea are doubled fields:

image

I want to have only English fields in submission form (I mean submission form fields like Title, Abstract, Keywords etc., not submission page which can be switched to Polish) so I tried to avoid it by changing all the multilingual attributes to false in MetadataFormTitleFields.tpl and submissionMetadataFormFields.tpl (in lib/pkp/templates/submission/submission) like below:

{fbvFormSection for=“title” title=“common.title” inline=“true” size=$fbvStyles.size.LARGE required=true}
{fbvElement type=“text” multilingual=false name=“title” id=“title” value=$title readonly=$readOnly maxlength=“255” required=true}
{/fbvFormSection}

but it didn’t help. Although form fields seem to look ok - they are all single and by default should be English - when I try to go to the next step with all the required fields filled I get the error message “Please enter the title of your article. (English)”. Even changing all required attribute to false didn’t help - I still get the same message.

image

Is there any way to get rid of multilingual fields in submission forms when submissions are allowed only in one language? I will be grateful for yor advices and help.

Hi @pavao,

That is configurable in Settings-Website-Lanugages:
59

If I understand correctly you would like to have Polish only UI, but not forms and submissions.

Regards, Primož

Hi, @primozs. I would be happy if it were so simply, but it’s not the case :slight_smile: In the first sentence of my post I wrote that “In website settings tab English is primary locale, UI and forms are checked for both languages, but submissions are allowed only in English.”:
image

Problem is that since forms are active both in Polish and English when submitting a paper there are still two fields for metadata (PL and EN) even if submissions are allowed only in English, as you can see from the image below:

image

Hi @pavao,

Have you tried to exclude Forms in Polish language?

Regards, Primož

@primozs, of course, but it is not the solution I need, because our website (also based on pkp/ojs, integrated with ojs) runs in two languages, so we need both English and Polish forms to edit its content.

Hi @pavao,

I agree with you, but what I am doing in such situations:

  • disable Forms per default
  • when want to change something (navigation, sections,…) enable Forms, do the change, disable Forms back

Agree that is not the best solution, but it works.

Regards, Primož