Missing journal sections

Hi again!

I have another issue with the journal section. Apparently the sections of the journal are stored in the database but not shown in the view. Like this:

It can be seen that the configuration is saved and can be modified but no information is displayed in the edit view except for checkboxs

can someone help me?
Thanks :smile: !

Julieta

Hi @julietavuan,

This seems like it might be locale-related. Are you working on a new translation or something similar?

Regards,
Alec Smecher
Public Knowledge Project Team

Hi Alec! No, i’m not workink on a new translation or any thing like it, i just want to see the information of the section journal in OJS 3.0 but i couldn’t.

If you see on the screenshot i have a journal on es_ES but in the view it doesnt’ show the info.

when i use var_dump() to see that is happening here:

and

this sis the result:

any ideas?

Julieta

Hi @julietavuan,

I wonder if this isn’t due to the incomplete upgrade we’re discussing on the other thread. Let’s try resolving that first.

Regards,
Alec Smecher
Public Knowledge Project Team

Hi Alec, it could be that, but the thing is that i didn’t have an “error” upgrading (at list not an error…). I had some PHP Notice, e.g.:

PHP Notice: unserialize(): Error at offset 59 of 3177 bytes in /home/user/ojs-3.0.0/lib/pkp/classes/db/DAO.inc.php on line 347

but not an Error.
Another partner made the upgrading and he didn’t have this problem, and we use the same database.
What can i do?

Hi @julietavuan,

The last step of the upgrade process is to change the version number in the database – if the database version isn’t updated, then the upgrade process didn’t complete.

Those unserialize warnings probably suggest that your database locale set somehow changed; make sure the configuration options for this are the same in your old and new config.inc.php configuration files.

Regards,
Alec Smecher
Public Knowledge Project Team

Hi Alec, I’m going to see both config.inc.php configuration files and try to upgrade again…
I hope to achieve this time
Thanks!
Julieta

HI Alec, i have this error at the moment:

What can i do?
Julieta

It sounds like in one config.inc.php file, the character encoding settings are unset and defaulting to MySQL’s “Latin1 (swedish)” default, and in the other config.inc.php file the character encodings are set to UTF8.

What were the settings before the upgrade, and what are the settings now?

Hi ctgraham, yes you were right. Now i return to the:

PHP Notice: unserialize(): Error at offset 234 of 1109 bytes in /var/www/html/ojs-3/lib/pkp/classes/db/DAO.inc.php on line 347

Notice: unserialize(): Error at offset 234 of 1109 bytes in /var/www/html/ojs-3/lib/pkp/classes/db/DAO.inc.php on line 347
PHP Notice: unserialize(): Error at offset 39 of 263 bytes in /var/www/html/ojs-3/lib/pkp/classes/db/DAO.inc.php on line 347

Notice: unserialize(): Error at offset 39 of 263 bytes in /var/www/html/ojs-3/lib/pkp/classes/db/DAO.inc.php on line 347
PHP Notice: unserialize(): Error at offset 242 of 1375 bytes in /var/www/html/ojs-3/lib/pkp/classes/db/DAO.inc.php on line 347

what Alec said is:

The last step of the upgrade process is to change the version number in
the database – if the database version isn’t updated, then the upgrade
process didn’t complete.

I’m using the tutorial to install OJS 3.0.0 and the database that i have in 2.4.8 and then i use:
" php tools/upgrade.php upgrade "
. How can i update the database?

Julieta

The process php tools/upgrade.php upgrade is correct to update the database.

  1. Be sure to completely erase the database and files_dir for any partial upgrades that you may have started.
  2. Then take a backup of your original 2.4.8 database and restore it as the new 3.x database.
  3. Take a backup copy of the 2.4.8 data files (files_dir) and restore it as the new 3.x. files_dir
  4. Ensure your config.inc.php character encoding settings are compatible from the 2.x config.inc.php to the 3.x config.inc.php.
  5. Run the database upgrade php.

Thanks ctgraham! I’m going to try it!
Hope it works!
:smile:

Julieta