Making author guidelines and ethics statement available to all

Our journal has author guidelines and an ethics statement, both of which are linked to on the submissions page. We would like these documents to be available to all, but unregistered users who try to click through are being directed to the login page.

I can’t see anything in the access settings that would restrict these documents – it’s an Open Access journal (see below). Any suggestions?

Hi @alunrichards,

does it mean that clicking About and then Author Guidelines causes a redirect of an unregistered user to login page? Which version of OJS do you use? Have you modified the installation somehow? Can you trace the HTTP requests e.g. using a Firefox web developer console (so that we can see if there are some dubious HTTP redirects when accessing <journal prefix>/about/submissions#authorGuidelines)?

We are running a slightly customised 2.4.5 and I did not have any problems of this kind. Open Access policy should not affect the way that the information about the journal is displayed.

Unless this is an error in your OJS installation or some misconfiguration, you could be also a victim of incorrect URL rewriting in case that you are using a custom set of URL rewriting rules - this is what I have been fighting with for some time.


Hi Jan,

Yes, when they click About and Author Guidelines they get redirected.

We’re using version I don’t believe it’s been modified in any way. I’m afraid I don’t know about tracing HTTP requests – I’m really just doing data entry!

Any help would be much appreciated.


Hi @alunrichards,

just got home to better internet connection so that I could check the Step 4 of our install (and the User Guide). Could you please provide the full snapshot of Section 4.1? Just below the text in the image that you posted, you should see a heading with checkboxes reading

Additional Site and Article Access Restrictions
[ ] Users must be registered and log in to view the journal site.
[ ] Users must be registered and log in to view open access content.

Unless you have the first checkbox activated, this really looks like a configuration issue (web server or OJS or both) to me.


Hi again,

Those boxes aren’t checked. Obviously it’s something a bit trickier!

Thanks for the help. I’ll have to raise it officially with the PKP people.



Hi @alunrichards,

The only limitation on the “About” page that would behave the way you describe is the checkbox identified above by @jprk; if that’s not checked, but you’re still seeing a login redirect on the About page, I wonder if something is behaving badly. Check to make sure that the permissions in your cache directory are set properly. One thing you could do is delete all .php files in cache/ and see if they get re-generated automatically when you browse the site. If you’ve recently upgraded or moved, this is a likely culprit.

Alec Smecher
Public Knowledge Project Team