Mail Template REVIEW_REQUEST not loading in Add Reviewer menu, also REVIEW_REMIND [OJS]

Dear OJS-Community,

because our OJS configuration contained a lot of outdated mail templates (especially BFR and OFR), all of which were always included in the Notify dropdown menu selection, I recently reset all mail templates.
Afterwards I transferred mail content customized by us back into the system (via Workflow > Email > Email Templates).
At first sight everything seemed to work. Now only the mails that are really relevant are displayed in the dropdown menu.

However, when adding new reviewers (Phase Review > Add Reviewers), the mail template REVIEW_REQUEST no longer appears in the corresponding selection menu. So at the moment we can not request reviewers.
Also resetting only the REVIEW_REQUEST mail template did nothing.

It is unclear to me what could be the reason for this.
Do you have any clues as to what could be causing this error?
How can I proceed now to narrow down this error?

Could maybe an OJS update to version 3.3.x help? We are currently using

Many thanks in advance,

Best regards

Dear Community,

because the problem unfortunately still exists and we can’t have any submissions reviewed at the moment, I have to turn to you again and hope that someone can help us.

I tried an update to OJS version today as a test. The problem persisted in version 3.3 as well, so I restored the backup from our current OJS version

In the reviewer request menu, the REVIEW_REQUEST mail template still does not load. Only the empty template (above) and the three mail templates we created ourselves appear. The text input field remains empty.

However, the problem does not only affect the REVIEW_REQUEST template, also the REVIEW_REMIND mail template is not loaded after clicking the “Send Reminder” button.

So it is a bigger problem than originally thought.

The cause was, as described above, resetting the mail templates. Even after resetting again, the corresponding templates could not be loaded. I tried this in version as well as in

I also tested both templates in English and German and also reloaded the Standard locales for each language. Nothing worked, neither templates are being loaded.

Could this be due to our database? I have read about the Bug in DB upgrade script (OJS 3.1.2-4 → OJS 3.2.1-2). But again, the error did not occur after an upgrade, but only after resetting the mail templates.

This is our email_templates_settings table (REVIEW_REQUEST hightlighted)
Screenshot 2021-02-18 083600

And this our email_templates_default_data table (REVIEW_REQUEST hightlighted)
Screenshot 2021-02-18 080720

To me they just look fine?

Any help or hints would be really appreciated!
Best regards and many thanks

The problem persists. We are very grateful for suggestions or advice on solutions!

Dear OJS-community,
finally I have made progress in solving this problem. The REVIEW_REQUEST email template is not loading because I have enabled one-click access for reviewers. When I unchecked it, the template loaded correctly.

I wonder how this can be? In OJS testdrive journal (Login | OJS3 Testdrive Journal) the loading of the template works even if the one-click access for reviewers is enabled.
Since I would like to use the one-click access as well, I am very happy to receive suggestions for a solution. For the time being I will do without this function.

Screenshot 2021-12-03 164841

Best regards,


Hi @adm_sub,

When the one-click reviewer access is turned on, the REVIEW_REQUEST_ONECLICK email template is used instead of REVIEW_REQUEST. Do you see that template present?

Alec Smecher
Public Knowledge Project Team

This topic was automatically closed after 11 days. New replies are no longer allowed.