Less than symbols truncating abstracts

I’ve noticed that when people submit abstracts containing < NOT followed by a space, it will truncate the abstract.

I’m using OCS version 2.3.5, and I’ve already seen this post on the old forum:
But I was unable to fix the problem.

Hi @emily,

Do you have the TinyMCE enabled for the abstract field?


Hi @beghelli,
Do you mean enabling the “TinyMCE Plugin” in “Generic Plugins” page?
Because this is also our problem and this plugin is enabled in this page.
It also creates such script errors as the attached photo and I have to correct the < sign from database.

This bug in tinyMCE is reported before, so, I am thinking of adding a regex replace option for more control. e.g:

$abstract = regexp_replace('(?<=[^\s])<(?=[^\s])', ' < ', $abstract);

but this affects the html codes like <strong> or <p> and will need a more complex regex.
Do you think this option will destabilize the software?