Labels lost on systeminfo-page after upgrade to

Dear all,

Something strange happened tonight when I was upgrading our two OJS-installations.

The first one worked just fine, but at the second installation something went wrong.
All labels on the systeminfo-page were gone and not all information visable.

This is how it looks.

The only thing I can think of is that the server with the errorous installation is running newer versions of PHP, MySQL and Ubuntu:

PHP 8.1.2-1ubuntu2.11
Ubuntu Server 22.04.2 LTS
mysql Ver 8.0.32-0ubuntu0.22.04.2 for Linux on x86_64 ((Ubuntu))

The server that went well is running
PHP 7.4.3-4ubuntu2.18
Ubuntu Server 20.04.5 LTS.
mysql Ver 15.1 Distrib 10.3.38-MariaDB, for debian-linux-gnu (x86_64) using readline 5.2

I had the same problem actually on a test server, so i’ve seen it before with the same version of OJS. Can’t access this server right now, so I can’t share versions of the software, but I think it is running Ubuntu 22.04.5 LTS as well.

Otherwise the installations are identical, since we just recently migrated the installation to split up our journals. The migration went fine.

I have reverted the installation to the previous version via a backup. How shall I proceed to upgrade without problems? Anyone encountered the same problem?

Best regards,
Tobias Carlsson

Hi @tbca,

Have you upgraded via Git or downloading the full package? Also, did you check the error log after the upgrade failure?

Best regards,

Josh Noronha (he, him, his)

You need to enable the PHP Intel extension. It however, may be, that you may run into other problems using OJS 3.3.0-14 with PHP 8.1 - we found it not to be compatible:


1 Like

Thank you!
The installation is clearly lacking php-intl, I will install it and see how it goes.
(It solved the problem on my test-server.)

Best regards,