Keyword Cloud Plugin for OJS3

plugin
ojs3

#1

Hi
I develop (mostly changed the old existing one) a keyword cloud plugin for ojs3.
I welcome any feedback for its improve.

and its my pleasure if it is added into the ojs3 plugin repository.
@asmecher

https://github.com/ali-sokhandan/ojs3-keywordcloud-plugin


#2

Hi @Azerilatama,

Excellent, this looks very good! I’ve added a couple of comments on the repo; let me know when you’re ready to package it up and I can walk you through the process. This would be a useful thing to document as well, so hopefully I can turn it into a blog post.

Regards,
Alec Smecher
Public Knowledge Project Team


#3

Hi
Dear @asmecher,
I fixed all the problems you mentioned. If there are OK, let me know what is the next step.

thanks.


#4

Nice contribution. Loved it.

A huge thanks.


#5

Thanks @Azerilatama for your great keywords plugin.

I have tried it but it did not show up in sidebar. The plugin checked in website setting --> plugin --> block and activated in appearance. I am using oldGregg theme https://github.com/Vitaliy-1/oldGregg


#6

dear @kawahyu
I tested myself on the oldGregg theme and the keyword block appeared on sidebar, could you check that is the keyword cache file (fc-keywords_[locale]_[journal ID].php) created? and is there any error related to the plugin exist in the php error log file.


#7

Hi @Azerilatama,
There is a problem somewhere, I don’t know where exactly.

I am able to install it properly in my localhost but have the same problem as @kawahyu in my webserver. My localhost is basically a copy of web files.

No fatal errors in PHP error_log. I see fc-keywords_en_US-1.php file in my localhost but not in the web server.

I even tried with the default theme and it does not appear in the homepage.

I guess, some php module has to be activated for this plugin to work properly, but which? Or is there some other solution?


#8

Hi @anupent

I confused too, i tested it in different situation but as you mentioned, it works on localhost but not in webserver. I don’t think it require a special php module, because I don’t use any special feature.
let me dig a little further, I hope to find the reason.


#9

dear @kawahyu and @anupent.
I think I solve the problem, could you please check again to see is it work on your server or not?


#10

will try later today. Will update.

Edit: Still not displayed in homepage. And, no obvious errors in php error_log.


#11

can you delete your cash files and try again.
I test it several time in web-server and it work without problem.


#12

Same as @anupent
I even re-installed the plugin by downloading the zip files in github. Clear data cache and template cache
@Azerilatama any example of the plugin in online Ojs web?


#13

Hi all,

If the plugin is showing up in the journal settings area but not displaying on the sidebar, it’s probably not been registered with the system properly. Make sure you install it via the “upload plugin” tool in the system plugins area, or via the Plugin Gallery (once it’s been approved and added there).

If you do install it manually, make sure it’s in the right subdirectory (plugins/blocks/keywordCloud), and you may need to also run…

php lib/pkp/tools/installPluginVersion.php plugins/blocks/keywordCloud/version.xml

…to register it with the system. (This won’t be necessary if you install it using the normal means described above.)

Regards,
Alec Smecher
Public Knowledge Project Team


#14

hi @kawahyu
I am really confused !!
i test it here: http://safirenoor-ngo.ir/ojs/index.php/test


#15

Cheer up @Azerilatama,

As @asmecher has adviced, I packed the files as .tar.gz and installed it by “upload a new plugin” method.
Voila, it is now visible in our website https://jlmc.edu.np

Thank you for this nice plugin.

Best regards,


#16

what do you name it? keywordcloud.tar.gz?
I tried uploading with that name, the notification is as follow

Notification The uploaded plugin archive does not contain a folder that corresponds to the plugin name.


#17

Hi @kawahyu,

I am not sure whether just renaming will do it. I used 7-zip (a free software) to zip it into .tar and then again into gzip. Also, make sure that a “keywordcloud” folder is there inside zipped archive. All other files should be within this folder.

If you have installed the plugin earlier delete it from the plugin tab in website setting, not from the server directly.

Then retry.

I hope it works.

Best regards,


#18

Here what I did
I extracted zip file downloaded from github then make a single folder named keywordcloud. With 7-zip, I created keywordcloud.tar.gz
It did not work either
Would you mind share your tar.gz file?
Or help from @Azerilatama to make a tar.gz release of the plugin so it can be uploaded


#19

I create the tar.gz archive, i hope it work for you.

maybe the problem is from your saver. did you install any tar.gz plugin before?


#20

It might be. I never have one