Issue with PKP PN Plugin

we are using OJS
About one month ago we activated PKP PN Plugin for two journals, but still it shows: “Network Status: The PKP PLN does not know about this journal yet.”, and list of deposits is different from the one on the PKP guides (PKP Preservation Network). Screenshot is attached:

How could we solve this issue?

Thanks & Regards

1 Like

Hi @Ana_N

The PLN plugin logs its activity each time it runs in a directory called scheduledTaskLogs inside of your files_dir directory. Each log file begins with the name “PKPPLNDepositorTask” and would be date/time stamped and may contain error messages. If you don’t have these files, it’s an indication that the plugin may not be running. Please have your systems administrator look and report back.


Hi @jnugent

Our admin checked it, the log files are being created every day and here you may find the one from this morning:

Hi @Ana_N

Apologies for the late reply. Can you ask your systems admin to go back in the older PLN logs and look for logs that contain entries like this:

[2021-07-28 12:44:45] [Notice] Trying transfer deposit 29 (Issue: 86) (Local Status: [Packaged], Processing Status: [Unknown], Lockss Status: [Unknown])
[2021-07-28 12:44:45] [Notice] Posting the Atom file to staging server for deposit 29 (Local Status: [Packaged], Processing Status: [Unknown], Lockss Status: [Unknown]) - (Url: [], AtomPath: [/files/journals/3/pln/7B15BC46-8A2E-4FF7-B417-5C93FFD244E0/7B15BC46-8A2E-4FF7-B417-5C93FFD244E0.xml], Method: [PostFile])

Those entries indicate that something was packaged up and sent to the server. You’re certain that you’ve also agreed to the PLN terms on the plugin settings page?


Hi @jnugent
Please find below the message from our admin:

"We found very few of these but here is the complete log file from 4th July (The most recent was 2021-07-06):

[2021-07-04 12:07:30]
[2021-07-04 12:07:30] [Notice] Task process started.
[2021-07-04 12:07:30] [Notice] PLN Depositor executeActions started
[2021-07-04 12:07:30] [Notice] Depositor processing for Journal of World Economy: Transformations & Transitions.
[2021-07-04 12:07:30] [Notice] Getting service document.
[2021-07-04 12:07:31] [Notice] Processing deposit status updates.
[2021-07-04 12:07:31] [Notice] Processing updated content.
[2021-07-04 12:07:31] [Notice] Processing new content.
[2021-07-04 12:07:31] [Notice] Packaging content for deposit.
[2021-07-04 12:07:31] [Notice] Sending deposits to the PKP PN.
[2021-07-04 12:07:31] [Notice] Depositor processing for Journal of Social Sciences: Transformations & Transitions.
[2021-07-04 12:07:31] [Notice] Getting service document.
[2021-07-04 12:07:32] [Notice] Processing deposit status updates.
[2021-07-04 12:07:32] [Notice] Processing updated content.
[2021-07-04 12:07:32] [Notice] Processing new content.
[2021-07-04 12:07:32] [Notice] Packaging content for deposit.
[2021-07-04 12:07:32] [Notice] Trying package deposit 2 (Issue: 5) (Local Status: [New], Processing Status: [Unknown], Lockss Status: [Unknown])

Hi @Ana_N

so that last line, where it’s trying package deposit, what happened next? That can’t be the whole log - There should be a “Task Process Started” and a “Task Process Stopped” at the beginning and end. If you don’t see those, there’s a fatal error being generated some where, and that error is probably in your server error log. You can force this command to run from the command line with:

php tools/runScheduledTasks.php plugins/generic/pln/xml/scheduledTasks.xml

Although you may need to fudge the last run date for it in the scheduled_tasks database table. It’s set to run once a day and if you move the date back a few days it will run, otherwise it will not.


Hi @jnugent
Please see the admin’s response:


I have always sent the complete log file.
Here are two for comparison. One from 2021-07-06, and one the day after.

I have done as request for the manual test.
I reset the “last run” date in the scheduled_tasks database table and then ran

php tools/runScheduledTasks.php plugins/generic/pln/xml/scheduledTasks.xml

This produced the attached log file ’ PKPPNDepositorTask-6115309d94d9a-20210812.log’ and no errors in the webserver Apache log.


So, the first log file is not finished so that process died unexpectedly. The other two look okay but because nothing is being sent I suspect your issues are in a state where the PLN plugin is now skipping them. I’d reset the entries and try again, but this time do it from the command line.

The PLN plugin will fail if the issues cannot be exported using the NativeImportExportPlugin so you could also try that for each issue. If you get errors there, they won’t deposit.


Could you advise how to “reset the entries” and we’ll try running the command on the command line and monitoring the log live.


Hi @2020media

If you look at the status of the Deposits there is a blue arrow next to the ID number that when clicked will give you a link to do that.


Sorry for delay, we had to schedule time when we could do this together (client and ourselves).

  1. We updated date of plugins.generic.pln.classes.tasks.Depositor back a few days in MySQL
  2. The client Reset the entries usng the blue arrow.
  3. we ran on the command line php tools/runScheduledTasks.php plugins/generic/pln/xml/scheduledTasks.xml

MySQL table was updated with timestamp of when we ran the command and a log file was generated as follows

[2021-09-15 16:34:39]
[2021-09-15 16:34:39] [Notice] Task process started.
[2021-09-15 16:34:39] [Notice] PLN Depositor executeActions started
[2021-09-15 16:34:39] [Notice] Depositor processing for Journal of World Economy: Transformations & Transitions.
[2021-09-15 16:34:39] [Notice] Getting service document.
[2021-09-15 16:34:40] [Notice] Processing deposit status updates.
[2021-09-15 16:34:40] [Notice] Processing updated content.
[2021-09-15 16:34:40] [Notice] Processing new content.
[2021-09-15 16:34:40] [Notice] Packaging content for deposit.
[2021-09-15 16:34:40] [Notice] Trying package deposit 1 (Issue: 4) (Local Status: [New], Processing Status: [Unknown], Lockss Status: [Unknown])

So unfortunately I do not think anything worked differently
Client also ran the Native XML export and that worked OK.

Hi @Ana_N,

I see your journals are present in the PKP PN and already have some deposits preserved, so I guess you don’t have issues anymore.