Internal server error with no specific error

Hello everyone,

I’m trying to deploy OSJ but I’m having trouble starting the installation. Any help is greatly appreciated!

Server is running Ubuntu server 18.04.02 and has Virtualmin / webmin installed, through which I have added a new virtual server for OJS and created a new mysql database. I’ve followed the readme instructions and got to the OJS installation screen successfully, however once I enter all the required information, the installation throws an “Internal server error” without much info.

All pre-installation steps are OK and server is using PHP 7.2.19.

Apache error log:

[Wed Jun 26 22:23:46.148132 2019] [fcgid:warn] [pid 20120] [client] mod_fcgid: stderr: PHP Warning:  Declaration of InstallHandler::validate($request) should be compatible with PKPHandler::validate($requiredContexts = NULL, $request = NULL) in /home/ojsadmin/public_html/lib/pkp/pages/install/ on line 0
[Wed Jun 26 22:23:47.115712 2019] [fcgid:warn] [pid 20121] [client] mod_fcgid: stderr: PHP Warning:  count(): Parameter must be an array or an object that implements Countable in /home/ojsadmin/public_html/cache/t_compile/e8ea13aa559bf8604ca823015b397a28d8666486^ on line 136, referer:
[Wed Jun 26 22:26:36.509033 2019] [fcgid:warn] [pid 22197] [client] mod_fcgid: read data timeout in 40 seconds, referer:
[Wed Jun 26 22:26:36.509111 2019] [core:error] [pid 22197] [client] End of script output before headers: index.php, referer: http://realdomainhidden/index.php/index/install

One note, OJS installation detects MySQLi while it shows brackets for all other options.

Please let me know if you need any more information. I’ve searched the forum for this error but I couldn’t find anyone with similar issue. Apologies in advance if this was already covered elsewhere.

Thank you!

Hi @mono,

This problems looks like associated with your environment. Have you browsed SO for answer? E.g.: perl - "End of script output before headers" error in Apache - Stack Overflow

1 Like

Hi @Vitaliy,

Thanks for the prompt response! Indeed you are correct. I’ve found the culprit, PHP script max run time was set to 40 seconds by default in Virtualmin. Once I increased it, installation could complete (as it takes a few mins).

The third line from errors above revealed the culprit:

[Wed Jun 26 22:26:36.509033 2019] [fcgid:warn] [pid 22197] [client] mod_fcgid: read data timeout in 40 seconds, referer:

First two lines above are just warnings and can be disregarded.

For the sake of helping others, if you’re using webmin / virtualmin as me, you can increase the PHP script max run time if you go to Virtualmin > your virtual server > Server Configuration > Website Options. Once that is done, it will complete the installation successfully.


1 Like