Installation weird behaviour

Dear ALl,

I am hoping someone will be able to help solve this installation dilemma as I have tried numerous ways just to get this installed but keep getting the same results and any online search does not produce any tangible solution either.

The issue is (which I have seen old online post on but no resolution) that after the first page of the installation OJS produces nothing other than a blank white page.

  1. I have crossed checked all permissions and even went as far as 777 on all files and folders up to the web root just to cross check yet the situation was the same.

  2. The server (hardware is more than adequate) is a bare metal with just the prerequisite LAMP stack and the php extensions installed and only OJS as an app on there

  3. I have tried with php7.2 (and even throttled back to trying with older versions to test more) and the same result each time (white page after the first install page) PHP is not the issue as I get my page so php is working.

  4. The “odd” thing I have noticed is on the URL of the white page that shows it seems to be linking to this “…m/ojs/index.php/index/install/install” and if I follow that path I do not see any folder or file that is related to that path.

  5. The server is dedicated so I have both physical and full root access.

  6. I have even tried with SSL and without as well and went as far as trying various versions even 3.1.2-4 using both PKP and OJS downloads and still the same result.

Thus, I hope someone can point me in the right direction here as I should like to put this app to the test being the first time trying to ever install it.


Hi @Fuquan,

Check your PHP error log for details.

Alec Smecher
Public Knowledge Project Team

Dear Alec,

Thanks a million for the pointer as while I was troubleshooting it as a “PHP” issue it was actually a MySql issue as somehow I guess I had changed the selectio to MySQLi but it had slipped back to MySQL without my noticing it. And I am sure during the focus on PHP I had not spotted this. As you can see from the attachment it installed flawless thanks once more. But since I saw this issue a few times I hope somehow incase someone else experiences this it may be prudent to document somewhere that attention needs to be paid to the Database box selection. Anyway, from tomorrow I will I will pick up form here and check out OJS as a few other things to do now.

Have a nice weekend


Hi @Fuquan,

Glad to hear you got it going!

Alec Smecher
Public Knowledge Project Team