Install ojs 3.1.1.4 PHP version 7.2 , Fatal error: Uncaught Error: Call to undefined function mysql_connect()

Hello ,

After the update ojs from 3.1.1.2 to 3.1.1.4 once i click on current issue will show me error .

Fatal error : Uncaught Error: Call to undefined function mysql_connect() in /data/apps/journalsys/lib/pkp/lib/adodb/drivers/adodb-mysql.inc.php:456 Stack trace: #0 /data/apps/journalsys/lib/pkp/lib/adodb/adodb.inc.php(558): ADODB_mysql->_connect(‘localhost’, ‘ojs’, ‘OJS88@018’, ‘ojs246’) #1 /data/apps/journalsys/lib/pkp/classes/db/DBConnection.inc.php(144): ADOConnection->Connect(‘localhost’, ‘username’, ‘password’, ‘ojs246’, false) #2 /data/apps/journalsys/lib/pkp/classes/db/DBConnection.inc.php(119): DBConnection->connect() #3 /data/apps/journalsys/lib/pkp/classes/db/DBConnection.inc.php(76): DBConnection->initConn() #4 /data/apps/journalsys/lib/pkp/classes/db/DBConnection.inc.php(52): DBConnection->initDefaultDBConnection() #5 /data/apps/journalsys/lib/pkp/classes/db/DBConnection.inc.php(220): DBConnection->__construct() #6 /data/apps/journalsys/lib/pkp/classes/core/PKPApplication.inc.php(170): DBConnection::getInstance() #7 /data/apps/journalsys/classes/core/Application.inc.php(38): PKPApplication->__construct() #8 /data/a in /data/apps/journalsys/lib/pkp/lib/adodb/drivers/adodb-mysql.inc.php on line 456

one more thing i already change the database from mysql to mysqli

someone can help me please to solve this problem

Regards

in config.inc.php change the driver type to mysqli.

edit: and just as I pressed send, saw that you did that already…

Are you 100% sure you edited the config.inc.php and not mistakenly config.TEMPLATE.inc.php?

for sure i update only config.inc.php to mysqli .

i have many issues only one issue it;s not working when i click on current button only show me the error everything working fine only current button if i click the error will appear again .

Thanks

Very weird. You could of course try to clear the OJS file cache.

Is it possible, that you have some own custom code on the current issue page?
If you access the latest issue through the archive, do you get the same error?

No , only current button when i click will show me the error here is the link , please have a look

http://ojs.mediu.edu.my/index.php/majmaa/

thanks

you get the same error if you go to Archives and access the latest issue from there. http://ojs.mediu.edu.my/index.php/majmaa/issue/view/101

So the problem occurs with only that single issue.

Did you try to empty the OJS file cache?

YES , I cleared data chache , clear template cache.

No thing change :frowning:

I m using the latest version of OJS 3.1.1.4 why show me in the message There is a new version of OJS available!

I was unable to reproduce the mysql error you mention, but the message about a new version is correct. OJS 3.1.2 was recently released:

I am using OJS 3.1.2 so I don’t know if it helps but can confirm it works when driver = mysqli in config file.