Incorrect column specifier for column 'submission_id'

I just fresh installed the latest OJS, after that worked on the config.php and moved public folder from my OJS to the new installation folder. So it was time to run the upgrade script for the database.

When I run the script to upgrade my database I do get the followinng error

Incorrect column specifier for column ‘submission_id’

What do I do?

CREATE TABLE articles (
article_id bigint(20) NOT NULL,
locale varchar(5) DEFAULT NULL,
user_id bigint(20) NOT NULL,
journal_id bigint(20) NOT NULL,
section_id bigint(20) DEFAULT NULL,
language varchar(10) DEFAULT ‘en’,
comments_to_ed text,
citations text,
date_submitted datetime DEFAULT NULL,
last_modified datetime DEFAULT NULL,
date_status_modified datetime DEFAULT NULL,
status tinyint(4) NOT NULL DEFAULT ‘1’,
submission_progress tinyint(4) NOT NULL DEFAULT ‘1’,
current_round tinyint(4) NOT NULL DEFAULT ‘1’,
submission_file_id bigint(20) DEFAULT NULL,
revised_file_id bigint(20) DEFAULT NULL,
review_file_id bigint(20) DEFAULT NULL,
editor_file_id bigint(20) DEFAULT NULL,
pages varchar(255) DEFAULT NULL,
fast_tracked tinyint(4) NOT NULL DEFAULT ‘0’,
hide_author tinyint(4) NOT NULL DEFAULT ‘0’,
comments_status tinyint(4) NOT NULL DEFAULT ‘0’

Hi @OJS_Atd,

Can you turn on show_stacktrace in before running the upgrade?

Note that each time the upgrade fails you’ll need to restore your database and files area from backup. A failed upgrade may leave both in an indeterminate state between the two versions.

Alec Smecher
Public Knowledge Project Team