Images/Icons have disappeared

Dear all,

almost two years ago and thanks to the help in this site I was able to create a press at using OMP (link not working, as the press does not exist any more with that name).

My former department has since then changed its domain to and the name of the press to (so that non-Hispanic topics are also covered by the name). The problem is, that since then, most icons/images have disappeared.

As you can see in the attached screenshot, there are no icons for search or for the documents. The same happens with “Close” icons in forms, for example. However, if I enter throgh the problem is solved.

I suppose this has to do with the press name and domain change, but I do not know how to solve it because this is far from being my field. I have had a look at the configuration, and the base URL is, and is the Repository ID, should this help. Files Dir works fine (the only problem is with images, not with books) but it cannot be changed.

What should be changed, so that images are loaded? Is there a images directory path or something like that, which I can modify and solve this problem?

Many thanks in advance for your help.

Hi @SaSoeurJuliette

Hmmm… Those icons are from fontawesome integrated with CSS… I am not sure, but maybe clearing the OMP cache would help?


Have you updated your base_url setting in (+ clear omp and browser cache after that)

Thank you for your help, @ajnyga and @bozana. Unfortunately, clearing the OMP cache did not solve the problem and the base_url setting is set to the new URL, so that it seems not to be the cause.

The old url is hardcoded somewhere, this is from your css file:

Have you defined a base url here (see the bottom of the file)

Hi all,

I would also suggest checking the Javascript console. There may be a CORS rule configured in your server that is preventing FontAwesome from loading; this should be reported in the browser’s console.

Alec Smecher
Public Knowledge Project Team

Yes, that is true, there is the CORS notification: Cross-Origin Request Blocked: The Same Origin Policy disallows reading the remote resource at (Reason: CORS header ‘Access-Control-Allow-Origin’ missing).
But why is the old URL there? :open_mouth:

Dear @ajnyga and @bozana,

sorry for not having been able to try your solution earlier. I just defined the base url where @ajnyga suggested but nothing has changed. Unfortunately I do not understand anything from what @bozana said, so that I think I will just look for any file where the old URL appears and change it manually. Let’s see if that works.

Many thanks for your help.

I was not necessarely thinking that you should define the base url there, was just wondering if your problem was because the old url was defined there.But searching for the old domain both from the database and the installation files is probably a good idea.