Cant upgrade prom 3.0.0 to 3.02

I dont know why I sent you the first “ls” command, but the problem was that I put :225 in the end of file name, sorry for that.

But the point is the file is in place

3.0 was partially working, upgraded from an older version

I upgraded to 3.0.2. trying to solve that issues

for example:
In several places the pages remain loading something. without never finising

Hi @Diego_Saravia,

Ah, I see. Check your error log again – the section you quoted appears to start with the stack trace, but leaves out the actual error message (which should be the line just above that).

Regards,
Alec Smecher
Public Knowledge Project Team

Ok, that is the error

Fatal error: Cannot declare class ReviewReportPlugin, because the name is already in use in /var/www/erma.asades.org.ar/public_html/ojs7/plugins/reports/reviewReport/ReviewReportPlugin.inc.php on line 139
PHP Stack trace:
PHP 1. {main}() /var/www/erma.asades.org.ar/public_html/ojs7/tools/upgrade.php:0
PHP 2. OJSUpgradeTool->execute() /var/www/erma.asades.org.ar/public_html/ojs7/tools/upgrade.php:34
PHP 3. OJSUpgradeTool->upgrade() /var/www/erma.asades.org.ar/public_html/ojs7/lib/pkp/classes/cliTool/UpgradeTool.inc.php:64
PHP 4. Upgrade->__construct() /var/www/erma.asades.org.ar/public_html/ojs7/lib/pkp/classes/cliTool/UpgradeTool.inc.php:85
PHP 5. Upgrade->__construct() /var/www/erma.asades.org.ar/public_html/ojs7/classes/install/Upgrade.inc.php:25
PHP 6. PluginRegistry::loadAllPlugins() /var/www/erma.asades.org.ar/public_html/ojs7/lib/pkp/classes/install/Installer.inc.php:97
PHP 7. PluginRegistry::loadCategory() /var/www/erma.asades.org.ar/public_html/ojs7/lib/pkp/classes/plugins/PluginRegistry.inc.php:194
PHP 8. PluginRegistry::_instantiatePlugin() /var/www/erma.asades.org.ar/public_html/ojs7/lib/pkp/classes/plugins/PluginRegistry.inc.php:119
PHP 9. include() /var/www/erma.asades.org.ar/public_html/ojs7/lib/pkp/classes/plugins/PluginRegistry.inc.php:225

Regards
Diego Saravia

Hi @Diego_Saravia,

It sounds like you have multiple copies of the ReviewReportPlugin installed on your system. When upgrading the code, make sure you’re not mixing old and new codebases together; see the “Full Package” upgrade instructions in docs/UPGRADE.

Regards,
Alec Smecher
Public Knowledge Project Team

ok, THANK YOU VERY MUCH

Successfully upgraded to version 3.0.2.0

i insatalled also “sudo apt-get install php7.0-xml”, but system info says I am using php 5.6

My problems now are:

and they produce {“status”:true,“content”:"\n\n\t\t\tAyuda\n\t</a>\n\n\n\n

  • that several pages get things not finished, like the one I showed several mails earlier.

Hi @Diego_Saravia,

Those $$$call$$$ URLs are fine, but I suspect your browser is encountering a JS error that’s preventing it from processing the JSON responses those requests generate. Check your browser console for error messages.

Regards,
Alec Smecher
Public Knowledge Project Team

Yes
I have:

Pedido de origen cruzado bloqueado: La política de mismo origen no permite leer el recurso remoto en http://ekeko.org/lib/pkp/fonts/fontawesome/fontawesome-webfont.woff2?v=4.3.0. (Razón: encabezado CORS ‘Access-Control-Allow-Origin’ faltante). (desconocido)
downloadable font: download failed (font-family: “FontAwesome” style:normal weight:normal stretch:normal src index:1): bad URI or cross-site access not allowed source: http://ekeko.org/lib/pkp/fonts/fontawesome/fontawesome-webfont.woff2?v=4.3.0

I dont know why is searching in ekeko.org

That was and old domain, but is not more in config.inc.php nor in any file

is there any place in the database in wich I need to change that?

Hi @Diego_Saravia

Hmmm… It seems to be somewhere in CSS…

S. also Favicon unavailable - #7 by ctgraham and Images/Icons have disappeared - #7 by bozana

Could you try the solutions mentioned there?
Maybe to try to delete the cache and maybe search your OJS folders after that URL/domain?

Best,
Bozana

I was reading that posts:

  1. cleaning the cache: everything equal

  2. urls in source code

first one OK

second one from google, not OK, they have // in the front, how can I change that?

  1. .“But searching for the old domain both from the database and the installation files is probably a good idea.”
    There is no old domain “ekeko.org” in ojs files nor in apache2 config files
    Where must I search in database?: tables, fields?

  2. http://erma.calcula.org/lib/pkp/fonts/fontawesome/fontawesome-webfont.woff2?v=4.3.0 points to a biinary file. I think its ok

  3. I found that error in apache2 error log file:
    PHP 21. unserialize() /var/www/erma.asades.org.ar/public_html/ojs7/lib/pkp/classes/db/DAO.inc.php:347

  4. The URL i am using for getting the error is:
    http://erma.calcula.org/index.php/ERMA/$$$call$$$/tab/settings/access-settings-tab/show-tab?tab=users

that is in the admin->Usuarios y roles->usuarios
what I get is:
{“status”:true,“content”:"\n\n\t\t\tAyuda\n\t</a>\n\n\n\n

people could navigate the site as you can see in http://erma.calcula.org
the problem is in admin area, is almost imposible to get into a working area. You get this kind of errors, or you see rounding circles waiting forever.

Thanks very much for your help!!!

I was searching for ekeko in database.sql

cat database.sql | grep ekeko

and nothing

but if the data is serialized or crypted I will be unable to find that way

I think the worst problem I have is that, because I see the browser trying to get to ekeko.org several times

and I dont have any reference to ekeko.org in file system or apace config files

That was an old domain

Hmmm…
How did you clean the cache? Do you have any .css file in your OJS folder cache? Does that old domain maybe appears in those .css files in the cache folder?
Hmmm…

i erased all the files in the structure down the “cache” directory in ojs

I can see two css files
1-pkp-lib.css
1-stylesheet.css

they do not have anything with the word ekeko

But I do another test
I direct the domain ekeko.org to the new site, to see if something changes

and no, using the erma.calcula.org or even the old ekeko.org is the same

so i think that the principal problem is in:
error in apache2 error log file:
PHP Notice: unserialize(): Error at offset 71 of 73 bytes in /var/www/erma.asades.org.ar/public_html/ojs7/lib/pkp/classes/db/DAO.inc.php on line 347

Hi @Diego_Saravia

Hmmm… I wonder that you do not then have problems in the frontend… However, could you search the forum after “unserialize” and see if some solution solves your problem – it looks like your character set configuration has changed…

Best,
Bozana

OK
I changed the config file form utf-8 (as it came) to utf8

Now i do not have serialize error

But everything is the same

I do not get into any working administrative screen

This are javascript errors
Curiosly, if I use erma.calcula.org it report problems with ekeko.org
If I use ekeko reports errors with erma

I point two domains to the same server to avoid that but …

manageIssues:11 Uncaught SyntaxError: Unexpected token ;
UploaderHandler.js:258 Uncaught TypeError: Cannot read property ‘UPLOAD_MAX_FILESIZE’ of undefined
at UploaderHandler.js:258
at UploaderHandler.js:269
(anonymous) @ UploaderHandler.js:258
(anonymous) @ UploaderHandler.js:269
SiteHandler.js:133 Uncaught TypeError: Cannot read property ‘baseUrl’ of undefined
at proxyConstructor.$.pkp.controllers.SiteHandler.initializeTinyMCE (SiteHandler.js:133)
at proxyConstructor.$.pkp.controllers.SiteHandler [as constructor] (SiteHandler.js:80)
at proxyConstructor.$.pkp.classes.ObjectProxy.parent (ObjectProxy.js:112)
at new proxyConstructor (Helper.js:283)
at Function.$.pkp.classes.Helper.objectFactory (Helper.js:209)
at HTMLBodyElement. (jquery.pkp.js:37)
at Function.each (jquery.min.js:2)
at n.fn.init.each (jquery.min.js:2)
at n.fn.init.$.fn.pkpHandler (jquery.pkp.js:31)
at HTMLDocument. (manageIssues:16)
$.pkp.controllers.SiteHandler.initializeTinyMCE @ SiteHandler.js:133
$.pkp.controllers.SiteHandler @ SiteHandler.js:80
$.pkp.classes.ObjectProxy.parent @ ObjectProxy.js:112
proxyConstructor @ Helper.js:283
$.pkp.classes.Helper.objectFactory @ Helper.js:209
(anonymous) @ jquery.pkp.js:37
each @ jquery.min.js:2
each @ jquery.min.js:2
$.fn.pkpHandler @ jquery.pkp.js:31
(anonymous) @ manageIssues:16
j @ jquery.min.js:2
fireWith @ jquery.min.js:2
ready @ jquery.min.js:2
K @ jquery.min.js:2
manageIssues:1 Access to Font at ‘http://erma.calcula.org/lib/pkp/fonts/fontawesome/fontawesome-webfont.woff2?v=4.3.0’ from origin ‘http://ekeko.org’ has been blocked by CORS policy: No ‘Access-Control-Allow-Origin’ header is present on the requested resource. Origin ‘http://ekeko.org’ is therefore not allowed access.
manageIssues:1 Access to Font at ‘http://erma.calcula.org/lib/pkp/fonts/fontawesome/fontawesome-webfont.woff?v=4.3.0’ from origin ‘http://ekeko.org’ has been blocked by CORS policy: No ‘Access-Control-Allow-Origin’ header is present on the requested resource. Origin ‘http://ekeko.org’ is therefore not allowed access.
manageIssues:1 Access to Font at ‘http://erma.calcula.org/lib/pkp/fonts/fontawesome/fontawesome-webfont.ttf?v=4.3.0’ from origin ‘http://ekeko.org’ has been blocked by CORS policy: No ‘Access-Control-Allow-Origin’ header is present on the requested resource. Origin ‘http://ekeko.org’ is therefore not allowed access.

Hmmm… It should be find out where this old domain comes from, but I have no more ideas where you could look for it… :-\

OK, I cant find that where came ekeko from, but I solve the javascript problem

I apply that to apache:

and now I dont have any visible error

but everything is the same

what can I do?

I found that error in javascript , perhaps baseUrl one is related

submissions:11 Uncaught SyntaxError: Unexpected token ;
UploaderHandler.js:258 Uncaught TypeError: Cannot read property ‘UPLOAD_MAX_FILESIZE’ of undefined
at UploaderHandler.js:258
at UploaderHandler.js:269
SiteHandler.js:133 Uncaught TypeError: Cannot read property ‘baseUrl’ of undefined
at proxyConstructor.$.pkp.controllers.SiteHandler.initializeTinyMCE (SiteHandler.js:133)
at proxyConstructor.$.pkp.controllers.SiteHandler [as constructor] (SiteHandler.js:80)
at proxyConstructor.$.pkp.classes.ObjectProxy.parent (ObjectProxy.js:112)
at new proxyConstructor (Helper.js:283)
at Function.$.pkp.classes.Helper.objectFactory (Helper.js:209)
at HTMLBodyElement. (jquery.pkp.js:37)
at Function.each (jquery.min.js:2)
at n.fn.init.each (jquery.min.js:2)
at n.fn.init.$.fn.pkpHandler (jquery.pkp.js:31)
at HTMLDocument. (submissions:16)

SOLVED!

What I do:

  1. create a new instalation, It worked (with creation of database, and old databaseuser)

  2. change the config.php to old database

  3. copy files

So I dont know what was wrong