I'm not able to install the OJS in my PC


I’ve tryed to install several times the OJS in WINDOWS by:

  1. install ast version of XAMPP(with php, my sql, appache)
    2.testing the locahost for XAMPP which was ok
  2. downoading the zip of last verion of OJS
  3. copy the unzipped of OJS folder to the HOTDOCUMENTS of XAMPP
  4. Create a new folder named “files” on XAMPP folder
  5. fill in the form of OJS downloading on the locahost

The probem is that even though I’ve completed al the steps when I cick on “INSTALL OPEN JOURNAL SYSTEMS” nothink happens…I don’t even receive any error message and my loggin is stil not created
Can anyone help me please?

Which version of PHP you use in your XAMPP?


I’ve downloaded the entire pack of XAMPP which has PHP version, on WINDOWS.

However I think that my problem is related to the permissions, since I’m not able to remove the protection from the files edition and therefore my folders from OJS remain “read only”.

Since the XAMPP is directy stored on my internal hardware local C and I cannot modify its permissions, do you know how can I only modify it in the needed folders of the OJS?

Thank you

Le mer. 10 oct. 2018 à 19:50, Vedran Vucic pkp@forum.pkp.sfu.ca a écrit :

THere should be user access control in your windows so you can change access control.
WIndows usually applies rigid controls to windows/programfiles but not much to c://xampp
Go to Settings and check access control for user settings.

Hi @Mariana_Dias,

Don’t forget to check your server’s error log. The most common problem with XAMPP-based installations is the default 30-second PHP execution time limit being too short; this should show up in the log file if the limit is encountered during the installation process.

Alec Smecher
Public Knowledge Project Team

The problem is the following:

  1. When I first download the folder OJS from the internet it is ok since the option “read only” is blank

  2. Once I select “extract the files” to folder which is not zip the option “read only” is selected and I’m not able to remove it (ee that option in yellow)


Le mer. 10 oct. 2018 à 22:39, Vedran Vucic pkp@forum.pkp.sfu.ca a écrit :

The problem is that when I extract the files from the zipped folder of OJS, the new folder has files “read only” which cannot be edit
Therefore I’m not meeting the following conditions on my OJS folder:

  • public/ is writable: Yes
  • cache/ is writable: Yes
  • cache/t_cache/ is writable: Yes
  • cache/t_compile/ is writable: Yes
  • cache/_db is writable: Yes

Le mer. 10 oct. 2018 à 22:45, Alec Smecher pkp@forum.pkp.sfu.ca a écrit :

Hi @Mariana_Dias,

I’m afraid I can’t help you with those details – I haven’t used a Windows machine in a very long time.

Alec Smecher
Public Knowledge Project Team

1 Like

Hi @Mariana_Dias,
I have been using XAMPP in windows 10 and I have never come across the problem of permission.

I would like you to re-start with the followings in mind:

  1. Install XAMPP in drives other than C: i.e. in D:\ or any other you have.
  2. When you start XAMPP, run it as admin.
  3. Create a database from localhost/phpmyadmin
  4. Tick off (deselect) not to create database during installation of OJS.
  5. Increase the PHP execution time to 300 in XAMPP\PHP\php.ini file
  6. If you still have problem, check your php error_log

best regards,

Hi @anupent

Thank you a lot for your answer, let me just try to follow your own steps to check if it works in my PC

Thank you very much for your help in advance :slight_smile:

Le jeu. 11 oct. 2018 à 05:38, Anup Acharya pkp@forum.pkp.sfu.ca a écrit :

Hi @anupent

Jutst to let you know that it worked! I’ve already installed the OJS.

Thank you a lot for your help, the issue was actualy related to the execution time.

Best Regards,


Le ven. 12 oct. 2018 à 19:08, Mariana Dias diasmariana91@gmail.com a écrit :

1 Like