"https:" is missing from URL exported via Zotero (Embedded Metadata)

Hello everyone,

when I try to export articles from our OJS site to Zotero, the exported URL is missing “https:” as a prefix. Is there a way to fix this?

Thank you!

Hi @karatatatat

Have you checked if your metadata has url with HTTPS prefix?
If I am not wrong Zotero reads metadata in DublinCore standards. So I suggest you double check your article page source code in browser and look this chunk:

<meta name="DC.Identifier.URI" content="HTTPS_LINK_HERE"

Also look in your config.inc.php if this parameter base_url is set with https.

Israel Cefrin
Public Knowledge Project Team

Many thanks for the quick reply, Israel.

The link appears without https: in the source code but in the config.inc.php, base_url is set to https

What is your OJS version?

Did you change recently to HTTPS protocol? If so, did you clear your cache system?

Israel Cefrin
Public Knowledge Project Team

I use 3.02 and just tried to clear the cache, no progress. We had some trouble with getting OJS to accept https before. Here the link to the journal if relevant: Journal of Historical Network Research

The urls I see in your metadata are beginning with // without any https:. That is then also exactly how it is imported in Zotero with the Embedded Metatags translator, which usually prefers HighWire metatags (beginning with citations_) over DC tags. Can you change that?

Note, there is also a special Open Journal Systems translator, but this does not detect on your site. I would suggest you also to activate COinS, which can be useful for other reference management systems as well.

How exactly did you enable https in your site? Did you use the “force ssl” setting in config.inc.php or did you perhaps modify the OJS core?

Hi zuphilip,

many thanks for your reply. Can you give me a pointer where to I could change this within OJS?

Concerning COinS: I tried this before, but then the metadata export lists no URL at all, that was my reason to deactivate it for now.

The force_ssl = On option did not work for me. I found a workaround somewhere in a PKP forum, but I don’t remember how exactly I got it to work.

So it seems that this issue is also related to SSL (which I also blame for the Piwik plugin not working…)

Whatever the workaround was, it seems that it involved editing the OJS core? It looks like the modification is leaving the protocol out of every url and then https is probably forced with a server setting?

If this is the case, then it is hard to give any pointers.

I think that most users have been successful in enabling https with the force ssl setting, but of course there could be situations where it is more difficult. When it is enabled, OJS will add https to all those metadata links and elsewhere ase well. The citations_ metatags are handled by Google Scholar plugin in OJS. But basically all these metadata plugins use the same functions to show the url’s.

I see - many thanks for the explanation! I’ll try to revisit the forc_ssl approach

By activating COinS the metadata will be formatted as Context Object and saved in a Span. This is then a nonvisible part of the page, which will be recognized by several reference management software. It will not appear in the metadata export list.

What I meant to say is that with COinS activated, the metadata imported to Zotero contains no reference to the article URL at all. With COinS deactivated, the metadata imported to Zotero has a URL which is missing the “https:”. Between the two, for now I prefer the latter.

Hi all,

It sounds like some of you are using the COinS plugin with OJS 3.x. That’s not distributed as part of the .tar.gz because it needs updates – are you using a checkout from git? Or did you get the plugin somewhere else?

Alec Smecher
Public Knowledge Project Team