Http Error When Uploading a File in this Version ojs-3.3.0-8

Description of issue or problem I’m having:

Hi Good day Everyone,

Here’s my issue: I get the error when I try to upload a file while submitting a new file in the submission.

http error

and I double-check this before proceeding to change the permissions in our file directory.

from 755

to 777

But, the error is the same (HTTP error);

I updated/enabled it in our server’s apache file extension File info.


Here is in my


and I am confused on this in


I’m attempting to resolve this problem; this is the first time I’ve encountered this error. Previously, our website page was only available as an extension on the main website; however, the company has opted to convert the main website to the ojs for the time being. After converting the main website to ojs, an error occurred, and I attempted to read and understand some of the issues raised.

**Application Version: ojs-3.3.0-8

Hope you help me.



If this image belongs to your hosting file manager control panel, your file path is not correct.
I suggest you check it again.

Probably the pdf files of the articles are not displayed either?

Hi all,

Note that the files_dir should not be in the web root, or you risk malicious users attempting to upload and execute scripts on the server. See docs/ for details on securing your installation.

Alec Smecher
Public Knowledge Project Team

Hello Kerim;

Thanks for the reply;

This folder file was inside the OJS in my file dir = /home/usernamehost/public html/files.

and here is the cpanel home directory:

Home Directory1


Hi asmecher;

Thanks for the Info, I will check on that.

For now… trying to understand the release

Hi Aschmer;

I read the docs/ something confused on me. the file directory will point on this location like this, which is on my understanding is equivalent of the webroot setup. /home/userrootcpanel/public_html/files or /home/userrootcpanel/files.

i tried to put our domain on the file_dir = htpps:// but the error is the same.

  • Right now my journals website was stock on this error

this is my setting in cpanel


as you can see. the ojs system is inside the public_html folder but the file folder is outside the public_html folder

and the config is like this

files_dir = /home/myhost/ojsfiles

so your setting in config should be

files_dir = /home/philairph2022/files

and move the files folder there.

Hi @OJS_Darryl,

Having your files directory available through the web server e.g. at is exactly what you want to avoid. The files directory should not be accessible through the web server.

The files_dir setting in should be a path (e.g. /home/userrootcpanel/ojs_files). It should not be a URL (e.g. https://anything).

Alec Smecher
Public Knowledge Project Team

I’m not finished with this problem; I believe it’s a server connection issue…

As a result, I attempted to upgrade our database to the most recent version of ojs-3.3.0-9. In this forum, I started a new topic.
WARNING: I got this Error NavigationMenu has already attached while upgrading the ojs-3.3.0-9 this is for localhost using XAMPP.

I’ll return after the issue on the new topic is solved, because this topic is distinct from others, and this is a path error of the file directory.


Hi Everyone,

I’m attempting to migrate my database from XAMPP to Our Web Server. I attempted to upload the database ojs, which serves as a backup. I did not proceed with the upgrade because I had some issues with on my end, and I also did not receive a response to my new subject.

WARNING: I got this error

Here is my problem in Uploading the our database:


Hi All,

Hope everyone is okay here:

I got an error when I go to the Journal Page of our publication site:


Fatal error : Uncaught PDOException: SQLSTATE[42000]: Syntax error or access violation: 1055 Expression #2 of SELECT list is not in GROUP BY clause and contains nonaggregated column ‘philairp_newBetaGenCorei12.s.context_id’ which is not functionally dependent on columns in GROUP BY clause; this is incompatible with sql_mode=only_full_group_by in /home/philairph2022/public_html/lib/pkp/lib/vendor/doctrine/dbal/lib/Doctrine/DBAL/Driver/PDOConnection.php:78 Stack trace: #0 /home/philairph2022/public_html/lib/pkp/lib/vendor/doctrine/dbal/lib/Doctrine/DBAL/Driver/PDOConnection.php(78): PDO->prepare(‘select s.* fr…’, Array) #1 /home/philairph2022/public_html/lib/pkp/lib/vendor/laravel/framework/src/Illuminate/Database/Connection.php(361): Doctrine\DBAL\Driver\PDOConnection->prepare(Object(Illuminate\Database\Query\Expression)) #2 /home/philairph2022/public_html/lib/pkp/lib/vendor/laravel/framework/src/Illuminate/Database/Connection.php(664): Illuminate\Database\Connection->Illuminate\Database{closure}(Object(Illuminate\Data in /home/philairph2022/public_html/lib/pkp/lib/vendor/laravel/framework/src/Illuminate/Database/Connection.php on line 671

in my localhost xampp I did not ecounter on this, but when I tried to our web server the error shown.

I need your help



I have the same problem - HTTP Error
But I noticed one feature. A file up to 100KB in size is loaded without errors. The file is larger already with an error.
PHP, php ini are configured correctly. All rights are set to maximum for uploading files
But the problem was not solved.
Sorry for my English.