HTTP ERROR 500, This page isn’t working, Unable to install OJS-3.3 in Redhat

I’m encountering a problem with a 500 error message in my browser after migrating my website, OJS 3.3, from my XAMPP server to my Red Hat Enterprise 9.3 system. The server is equipped with Apache/2.4.57 and MariaDB: MySQL Ver 15.1 Distrib 10.5.22-MariaDB, and PHP 8.0.30. I’m unable to display the OJS page, as it gives me a 500 error, and there’s no error log available on the server. All permissions are set to 755, and the owner and group have been configured for Apache, plus my database was created properly and all tables was uploaded in my database connected with the same user who has the grant privilege for my database.

To be sure that the problem not related to my data, I tried installing an empty journal on my XAMPP server for testing purposes. I configured it only for the initial installation, and using PHPMyAdmin to set up the database and tables, then I upload every things with Filezila to my server. However, I encountered the same problem. So please I need a help.

For RHEL systems, the error log probably is in: /var/log/php-fpm/www-error.log

Thanks for the reply. Yesterday, I tried to download and extract again OJS 3.3 on my server direct, to check it before uploading my ojs website and ensuring that everything was properly configured. Unfortunately, I encountered an error stating that the Files Directory does not exist or is not writable. I tried several solutions, including giving full permissions (777) to my folder and creating multiple folders in different directories (e.g., /home/files or /var/files), i changed in the path of file, but the issue persisted. Could you please advise me on this which path should i insert, as I couldn’t find a solution in the forum? thanks again

For security, the files directory should be outside of the OJS root directory. However, it must be owned by the Apache process and be writable by it.

Thanks for your assist. Exactly i created already the directory outside the path of my ojs (/var/www/html/ojs), and my directory was created in /home/userXX/files/uploades (I tried only files, then i added uploades) with the privilege: drwxrwxr-x. 2 apache apache 6 Apr 25 09:33 uploads and drwxr-xr-x. 3 apache apache 21 Apr 25 09:33 files (so both of them are writable and apache:apache for user and group.
, then i edited my → files_dir = /home/files/uploades and this is the path used for installation /home/userXX/files/uploades BUT STILL SAME ERROR

Even i open completely all permission 777: # cd /home/userXXX/files/uploads → drwxrwxrwx. 2 apache apache and the path used during installation was: /home/userXXX/files/uploads/ still i have the same pb Errors occurred during installation
The directory specified for uploaded files does not exist or is not writable.

Could it be that a security setting such as selinux prohibits access?

Problem solved.
Solution: during the installation i disable selinux using the command setenforce

1 Like