How to fix function search not working

how to fix function search not working in ojs 3 php 7.3.33

Hi @mcahyoko,

Can you elaborate further on how it’s not working? Also: please give your specific OJS version (e.g. 3.3.0-13).

Best regards,

PKP Team

so the search function in our journal cannot be used

ojs version

Did you index the journal?

cd {ojsroot}/tools
php ./rebuildSearchIndex.php

Uploading: Screenshot_3.jpg…
when run error

Do as the error message tells - you need to install PHP version 7.3 or higher. This is also minimal version required by OJS 3.3 (see

it worked but still not working

This one is working:

And here, too, which finds an article of the IJMLST

Searching from the central index works. However, it is very slow.
Not sure what is going on that you can’t search in a specific journal. I think you should check your (as well as the .htaccess rewrite rules). And of course your PHP error log.

following is the error

but other journal function search is working only journal with new theme