How to create XSD format for Index Copernicus?


#21

I’d definitely like to help too, with pleasure. Thanks a lot for your quick response and taking a step ahead.

Regards


#22

Ok. I have done it.

There is a first try.

https://github.com/a-vodka/ojs_copernicus_export_plugin/blob/ojs3/downloads/copernicus3-0.0.2.tar.gz

If you find a bug, would you please create an issue on github.


#23

to get it work with OJS 3.1, in line 121;

  • $url .= “/index.php/$jpath/article/view/” . $article->getId() . ‘/’ . $files->getFile()->getAssocId();
  • $url .= “/index.php/$jpath/article/view/” . $article->getId() . ‘/’ . $files->getFileId();

By the way, I can export the issues in XML but, when I tried to load it in Index Copernicus panel, it gives error. I think it needs some moe work with regards to scheme definition. Does anybody know how to do it??

Regards


#24

Could you please attach you XML file. I am going to analyse it and validate it.


#25

Hello Oleksii,
You can find my xml file here, created with your exporter, http://www.injirr.com/copernicus-issue-2017-1.xml

Regards


#26

Let’s try to remove all html tags from abstract. You can do it manually. Please, let me know about results.


#27

I had tried it before I raised it here. It did not help. I guess there should be something to do with XSD rather than XML. I have found a tool on microsoft’s website called xsd.exe, which generates xsd files from a given xml. I have tried the xsd file generated with that tooli but still for no joy.

Regards


#28

I have checked xml validity of this file. It seems to be ok. I used Altova XML Spy. Also I have tried to upload example xml from Copernicus index site. I have got error too. So, I am going to write to Copernicus support. May be they can help me.


#29

I have written already to the support of IC. They did not respond yet. I’ll update here if I find a way to upload the file.


#30

Hello!
It work with OJS 3.1, By the way instituteAffiliation not coming in XML.

Regards,
Surojit


#31

Hello,
I have tried your plugin for OJS - 2.8.x, I have downloaded an issue from our journal and tried to upload it to IC site. I have the same error that you described. I contacted the IC team and I have an answer from IC, and maybe a solution to our problem:

Dear Prof.,
Unfortunatly, that plugin is out of date.
You have some different mistakes, such as: dateTime section is missing and time format of publicationDate section is wrong.

I attached the file .xsd so You can compare your file with standarts.
You can use this validator for example: https://www.freeformatter.com/xml-validator-xsd.html

Best regards,
Zespół Index Copernicus/Index Copernicus Team

Unfortunatelly I’m not a programmer to fix this so I’m asking you to help us all :smiley:
I cannot attach here the “ic-import.xsd” standard file received from IC, but it can be downloaded from IC site.
We have the right to use this, the IC team ensured us that the information is public.

Thank you a lot,
Best regards,
Sebastian


#32

Thank you for your replay. The update is available. This situation with publicationDate is fixed. I have checked, the XML file upload to Copernicus Index correctly.

for 2.8 https://github.com/a-vodka/ojs_copernicus_export_plugin/blob/master/downloads/copernicus-0.0.1.tar.gz
for 3.1 https://github.com/a-vodka/ojs_copernicus_export_plugin/blob/ojs3/downloads/copernicus3-0.0.2.tar.gz

@seb_m, @Surojit_Bera, @mukaanyes @varshilmehta @asmecher


#33

Hi, I am using 3.1.1.2 and uploaded your latest plugin.

I uploaded the XML file in the Index Copernicus, however it said its not valid or proper.

Or I am uploading somewhere wrong. Please let me know.


#34

Could you please send me your xml file?


#35

https://drive.google.com/file/d/1u_xDUemz-hn5Y3Vj9V7xkovTFTHClZn2/view?usp=sharing and https://drive.google.com/open?id=1M8mg48tgKodJ_iXIPEkqcwSo9FNASqH1
Here you go.


#36

The second file did work though/ I will see why the first didnt work. Thanks a ton


#37

I have fixed trouble with issn. Please find update on github. Could you please try again with fist file.


#38

It was not due to ISSN. Cos i did fix the ISSN. There is something else with the first file, cos the other two files did work.


#39

All problem are fixed


#40

Hi @a-vodka, thank you so much for the plug-in. Could you please upload it to the Plugin gallery? We have some problems installing it through the back-end. It keeps saying, that “The uploaded plugin archive does not contain a folder that corresponds to the plugin name.”

Also tagging @asmecher