Home ojs 3.2.11+oldGregg cannot be acces (fatal error)

Dear all,

I don’t know what happened, two days before it was still possible. Only the “home page” is blank, other pages are fine.

OJS versi, oldGregg theme, php 7.4:

error log:
[31-Jul-2021 15:08:41 Asia/Jakarta] PHP Fatal error: Uncaught Error: Call to a member function getLocalizedFullTitle() on null in /home/=username=/public_html/plugins/themes/oldGregg/OldGreggThemePlugin.inc.php:227
Stack trace:
#0 /home/=username=/public_html/lib/pkp/classes/cache/GenericCache.inc.php(63): OldGreggThemePlugin->_toCache(Object(FileCache), NULL)
#1 /home/=username=/public_html/lib/pkp/classes/cache/FileCache.inc.php(115): GenericCache->get(NULL)
#2 /home/=username=/public_html/plugins/themes/oldGregg/OldGreggThemePlugin.inc.php(181): FileCache->getContents()
#3 /home/=username=/public_html/lib/pkp/classes/plugins/HookRegistry.inc.php(107): OldGreggThemePlugin->browsePopular(‘TemplateManager…’, Array)
#4 /home/=username=/public_html/lib/pkp/classes/template/PKPTemplateManager.inc.php(906): HookRegistry::call(‘TemplateManager…’, Array)
#5 /home/=username=/public_html/pages/index/IndexHandler.inc.php(66): PKPTemplateManager->display(‘frontend/pages/…’)
#6 /home/=username=/public_html/lib/pkp/classes/core/PKPRouter.inc.php(391): IndexHandler->index(Array, Obje in /home/=username=/public_html/plugins/themes/oldGregg/OldGreggThemePlugin.inc.php on line 227

Can I get help?

Hi @sasha_kinanti,

Looks like the publication that is cached by a theme plugin got removed or unpublished. Can you specify the version of the Old Gregg theme for me to reproduce?

@sasha_kinanti, are there any updates on this one? Can you specify the version of the Old Gregg theme and confirm that the error is related to the publication being unpublished?

Halo Prof,
Thanks for the response.
Sorry, I’m busy redesigning the journal, so I don’t have time to update the forum.
I’m using OldGregg version on OJS
When the journal activity is busy, not long after, an error.
but only the “home page” is not accessible. other pages can still be accessed.
I tried to re-install, still not working.