Help with Gmail Setting

@pmangahis we are using ojs 3, if we send email to authors by OJS system.We have noticed that by gmail detail via srv392.main-hosting-eu and mailed by srv392.main-hosting-eu How we can replace this with our journal information. Thanks

Hi @Ali12,

Thanks for your question. As you had originally posted this on an unrelated topic, I’ve gone ahead and created a separate one on your behalf.

I wanted to confirm whether you have consulted the Email already?

Kind Regards,
Public Knowledge Project Team

@pmangahis Thank you so much for your prompt reply. Sorry to posted unrelated topic here. In config.Inc.php our email setting details below, Even we have added one of our gmail in smtp username and smtp password. But not observed any changes. Please could you help us, how we solve this issue?
; Email Settings ;


; Use SMTP for sending mail instead of mail()
; smtp = On

; SMTP server settings
; smtp_server =
; smtp_port = 25

; Enable SMTP authentication
; Supported mechanisms: ssl, tls
; smtp_auth = ssl
; smtp_username = username
; smtp_password = password

; Allow envelope sender to be specified
; (may not be possible with some server configurations)
; allow_envelope_sender = Off

; Default envelope sender to use if none is specified elsewhere
; default_envelope_sender =

@pmangahis If email send by our OJS 3, On gmail details showing like that. Please check it below. Want to replace those via and mailed by address with our journal domain. We have contacted with our hosting person, they said this setting is not in our hand.

from: Dr. XXX via
reply-to: Open Journal Systems
to: xx
date: Jul 22, 2021, 8:06 PM
subject: [XXX] Password Reset Confirmation

Hi @Ali12

The “via” part is the address you’d define in the default_envelope_sender field in your file. It’s also used as the second part in the dmarc_compliant_from_displayname setting.

You can use whatever you want in the default_envelope_sender, but whatever domain you include there should have a properly configured SPF record in that domain’s DNS.

Here is a handy tool for generating your DNS SPF record:

Once you have that record you will need to talk to whoever maintains the DNS for the domain of the email address you want to use there.


Hi @Ali12,

Just to check one thing – are you leaving the ; characters in front of the settings you’re changing? A line starting with a ; is considered to be a comment, and won’t be read by OJS. If you want to change a setting, make sure that line doesn’t start with a ;.

Alec Smecher
Public Knowledge Project Team

@asmecher Thank you for your reply. Now the sending email to the authors from the OJS is okay, but if we removed ; from the starting line, then we have checked the OJS not send email to authors, don’t know which setting is okay now. But we have a sender and mailed by address issue. The rest sending email from the OJS to authors is fine.